Gentoo updating perl with many masked and blocked packages

After our previous howto Gentoo – update dev-libs/icu on a desktop box with KDE GUI and many masked packages we want to show you another example of how to update perl, which could have hundreds dependencies installed as perl modules. You can check for more details above howto, details about what to do when there are masked and blocked packages, because here we use only some of the options we have the proper ones for this case.
Just to note when updating perl you must reinstall (recompile, rebuild) all the external modules (additional packages) and all perl modules installed with CPAN module (if you do not know what is this, you probably have not used it so no worries).

How we managed to update in our current situation:

  • use qlist to update/re(build) to pull currently installed packages with some name or category (categories)
  • Add or remove USE flags if needed – emerge will show you information about it. Use package.use, package.mask, package.unmask and so on.
  • Use verbose,verbose-conflicts and backtrack with emerge
  • Include explicitly packages, which block our updates in the emerge line! You could specify packages with the versions.

More on the subject of Perl update tips here: Gentoo update tips when updating packages with blocks and masked files
And a new article on the subject – Gentoo – updating perl and problems like perl-core/ is blocking virtual/perl-

Our real world example

So we are root and in a console:

root@srv ~ # emerge -vu perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  r  U  ] dev-lang/perl-5.26.2:0/5.26::gentoo [5.24.1-r2:0/5.24::gentoo] USE="berkdb gdbm ithreads -debug -doc" 11770 KiB
[ebuild  rR    ] virtual/perl-Exporter-5.720.0-r3::gentoo  0 KiB
[ebuild  r  U  ] virtual/perl-Scalar-List-Utils-1.460.200_rc::gentoo [1.460.0-r1::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo  19 KiB
[ebuild  rR    ] dev-perl/HTML-Tagset-3.200.0-r1::gentoo  8 KiB
[ebuild  rR    ] dev-perl/TimeDate-2.300.0::gentoo  31 KiB
[ebuild  rR    ] dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3
[ebuild  rR    ] perl-core/File-Path-2.130.0::gentoo  31 KiB
[ebuild  rR    ] dev-perl/Net-Daemon-0.480.0-r2::gentoo  29 KiB
[ebuild  rR    ] perl-core/File-Temp-0.230.400-r1::gentoo  59 KiB
[ebuild  rR    ] virtual/perl-if-0.60.600-r2::gentoo  0 KiB
[ebuild  rR    ] dev-perl/GSSAPI-0.280.0-r1::gentoo  USE="-test" 67 KiB
[ebuild  rR    ] dev-perl/Socket6-0.280.0::gentoo  65 KiB
[ebuild     U  ] app-text/qpdf-8.1.0:0/21::gentoo [7.0.0:0/18::gentoo] USE="perl -doc -examples -static-libs -test" 8051 KiB
[ebuild  rR    ] dev-perl/XML-Parser-2.440.0::gentoo  232 KiB
[ebuild  rR    ] virtual/perl-ExtUtils-CBuilder-0.280.225-r2::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Text-CharWidth-0.40.0-r1::gentoo  9 KiB
[ebuild  rR    ] virtual/perl-ExtUtils-Install-2.40.0-r3::gentoo  0 KiB
[ebuild  rR    ] perl-core/Module-CoreList-5.201.806.260::gentoo  103 KiB
[ebuild  rR    ] virtual/perl-ExtUtils-Constant-0.230.0-r11::gentoo  0 KiB
[ebuild  rR    ] dev-perl/IO-String-1.80.0-r1::gentoo  8 KiB
[ebuild  r  U  ] virtual/perl-Text-Balanced-2.30.0-r4::gentoo [2.30.0-r3::gentoo] 0 KiB
[ebuild  rR    ] media-libs/exiftool-11.03::gentoo  USE="-doc" 4311 KiB
[ebuild  rR    ] dev-perl/YAML-Syck-1.300.0::gentoo  167 KiB
[ebuild  r  U  ] virtual/perl-Math-Complex-1.590.100-r1::gentoo [1.590.0-r9::gentoo] 0 KiB
[ebuild  r  U  ] virtual/perl-Params-Check-0.380.0-r7::gentoo [0.380.0-r6::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/Package-Constants-0.60.0::gentoo  4 KiB
[ebuild  rR    ] app-doc/NaturalDocs-1.52-r1::gentoo  450 KiB
[ebuild  r  U  ] virtual/perl-Pod-Parser-1.630.0-r4::gentoo [1.630.0-r3::gentoo] 0 KiB
[ebuild  r  U  ] virtual/perl-CPAN-Meta-Requirements-2.140.0-r3::gentoo [2.140.0-r2::gentoo] 0 KiB
[ebuild  r  U  ] virtual/perl-Pod-Simple-3.350.0-r1::gentoo [3.320.0-r1::gentoo] 0 KiB
[ebuild  r  U  ] virtual/perl-Module-Load-Conditional-0.680.0-r1::gentoo [0.640.0-r3::gentoo] 0 KiB
[ebuild  r  U  ] virtual/perl-Module-Load-0.320.0-r6::gentoo [0.320.0-r5::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/String-ShellQuote-1.40.0-r1::gentoo  7 KiB
[ebuild  r  U  ] virtual/perl-Locale-Maketext-Simple-0.210.100_rc-r7::gentoo [0.210.100_rc-r3::gentoo] 0 KiB
[ebuild  rR    ] virtual/perl-File-Temp-0.230.400-r5::gentoo  0 KiB
[ebuild  rR    ] virtual/perl-File-Path-2.130.0::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Text-WrapI18N-0.60.0-r1::gentoo  4 KiB
[ebuild  rR    ] dev-perl/XML-RegExp-0.40.0-r1::gentoo  4 KiB
[ebuild  rR    ] dev-perl/libxml-perl-0.80.0-r2::gentoo  63 KiB
[ebuild  rR    ] virtual/perl-Module-CoreList-5.201.806.260::gentoo  0 KiB
[ebuild  r  U  ] dev-lang/perl-5.24.4:0/5.24::gentoo [5.24.1-r2:0/5.24::gentoo] USE="berkdb gdbm ithreads -debug -doc" 11333 KiB
[ebuild  r  U  ] virtual/perl-Compress-Raw-Bzip2-2.74.0-r1::gentoo [2.69.0-r1::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/URI-1.730.0::gentoo  USE="-test" 105 KiB
[ebuild  rR    ] dev-perl/HTTP-Date-6.20.0-r1::gentoo  8 KiB
[ebuild  rR    ] dev-perl/HTML-Parser-3.720.0::gentoo  USE="-test" 89 KiB
[ebuild  rR    ] dev-perl/TermReadKey-2.370.0::gentoo  USE="-examples" 84 KiB
[ebuild  rR    ] dev-perl/Encode-Locale-1.50.0::gentoo  USE="-test" 9 KiB
[ebuild  rR    ] dev-perl/Text-Unidecode-1.300.0::gentoo  135 KiB
[ebuild  rR    ] dev-perl/Net-SSLeay-1.820.0::gentoo  USE="-examples -libressl -minimal -test" 390 KiB
[ebuild  rR    ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo  31 KiB
[ebuild  rR    ] dev-perl/IPC-System-Simple-1.250.0::gentoo  USE="-test" 30 KiB
[ebuild  rR    ] dev-perl/PlRPC-0.202.0-r3::gentoo  18 KiB
[ebuild  rR    ] dev-perl/Digest-HMAC-1.30.0-r1::gentoo  8 KiB
[ebuild  rR    ] dev-perl/MailTools-2.190.0::gentoo  USE="-examples -test" 55 KiB
[ebuild  rR    ] dev-perl/libintl-perl-1.280.0::gentoo  460 KiB
[ebuild  rR    ] dev-perl/IO-HTML-1.1.0::gentoo  USE="-test" 19 KiB
[ebuild  rR    ] dev-perl/Sub-Name-0.210.0::gentoo  USE="-suggested -test" 80 KiB
[ebuild  rR    ] dev-perl/XML-NamespaceSupport-1.120.0::gentoo  USE="-test" 18 KiB
[ebuild  rR    ] dev-perl/ExtUtils-PkgConfig-1.160.0::gentoo  10 KiB
[ebuild  rR    ] dev-perl/XML-SAX-Base-1.90.0::gentoo  USE="-test" 28 KiB
[ebuild  rR    ] dev-perl/common-sense-3.740.0-r1::gentoo  13 KiB
[ebuild  rR    ] dev-perl/Locale-gettext-1.70.0::gentoo  9 KiB
[ebuild  rR    ] dev-perl/ExtUtils-Depends-0.405.0::gentoo  USE="-test" 18 KiB
[ebuild  rR    ] perl-core/Test-Simple-1.302.96::gentoo  USE="-examples" 276 KiB
[ebuild  rR    ] dev-perl/MIME-Charset-1.12.2::gentoo  L10N="-ja -zh" 55 KiB
[ebuild  rR    ] dev-perl/Locale-Maketext-Lexicon-1.0.0::gentoo  USE="-test" 90 KiB
[ebuild  rR    ] dev-perl/Text-CSV_XS-1.340.0::gentoo  USE="-examples -test" 170 KiB
[ebuild  rR    ] dev-perl/List-MoreUtils-XS-0.426.0::gentoo  USE="-test" 156 KiB
[ebuild  rR    ] dev-perl/Canary-Stability-2012.0.0::gentoo  5 KiB
[ebuild  rR    ] dev-perl/IO-stringy-2.111.0::gentoo  41 KiB
[ebuild  rR    ] dev-perl/YAML-Tiny-1.730.0::gentoo  USE="-minimal -test" 72 KiB
[ebuild  rR    ] dev-perl/XML-XPath-1.420.0::gentoo  USE="-examples -test" 55 KiB
[ebuild  rR    ] dev-perl/Exporter-Tiny-1.2.1::gentoo  USE="-examples -test" 32 KiB
[ebuild  rR    ] dev-perl/Log-Agent-1.1.0::gentoo  USE="-test" 55 KiB
[ebuild  rR    ] dev-perl/YAML-1.260.0::gentoo  USE="-test" 85 KiB
[ebuild  rR    ] dev-perl/Net-Telnet-3.40.0::gentoo  40 KiB
[ebuild  rR    ] perl-core/Scalar-List-Utils-1.460.0::gentoo  USE="-test" 0 KiB
[ebuild  rR    ] dev-perl/Archive-Zip-1.600.0-r1::gentoo  USE="-examples -test" 187 KiB
[ebuild  rR    ] dev-perl/Date-Manip-6.600.0::gentoo  USE="-test" 1783 KiB
[ebuild  rR    ] dev-perl/Digest-SHA1-2.130.0-r1::gentoo  39 KiB
[ebuild  rR    ] sys-apps/texinfo-6.5::gentoo  USE="nls -static" 4398 KiB
[ebuild  rR    ] dev-perl/HTTP-Message-6.130.0::gentoo  USE="-test" 73 KiB
[ebuild  rR    ] dev-perl/IO-Socket-SSL-2.52.0::gentoo  USE="-examples -idn" 217 KiB
[ebuild  rR    ] dev-perl/Try-Tiny-0.300.0::gentoo  USE="-minimal -test" 34 KiB
[ebuild  rR    ] dev-perl/DBI-1.637.0::gentoo  USE="-examples -test" 583 KiB
[ebuild  rR    ] dev-perl/WWW-RobotRules-6.20.0-r1::gentoo  9 KiB
[ebuild  rR    ] dev-perl/CGI-4.400.0::gentoo  USE="-examples -test" 196 KiB
[ebuild  rR    ] dev-perl/Authen-SASL-2.160.0-r1::gentoo  USE="kerberos" 45 KiB
[ebuild  rR    ] dev-perl/File-Listing-6.40.0-r1::gentoo  51 KiB
[ebuild  rR    ] dev-perl/Module-Build-0.422.400::gentoo  USE="-test" 298 KiB
[ebuild  rR    ] dev-perl/XML-SAX-1.0.0::gentoo  46 KiB
[ebuild  rR    ] perl-core/Archive-Tar-2.300.0::gentoo  USE="-test" 63 KiB
[ebuild  rR    ] dev-perl/Unicode-LineBreak-2017.4.0-r1::gentoo  305 KiB
[ebuild  rR    ] dev-perl/Types-Serialiser-1.0.0-r1::gentoo  7 KiB
[ebuild  rR    ] dev-perl/glib-perl-1.326.0::gentoo  291 KiB
[ebuild  rR    ] virtual/perl-Test-Simple-1.302.96::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Font-TTF-1.60.0::gentoo  251 KiB
[ebuild  rR    ] dev-perl/List-MoreUtils-0.426.0::gentoo  USE="xs -test" 143 KiB
[ebuild  rR    ] dev-perl/Text-CSV-1.950.0::gentoo  USE="xs -test" 112 KiB
[ebuild  rR    ] app-misc/hivex-1.3.14::gentoo  USE="perl python readline -ocaml -ruby -static-libs -test" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6"
ETS="ruby23 ruby24%* -ruby25% (-ruby22%)" 1302 KiB
[ebuild  rR    ] dev-perl/File-BaseDir-0.70.0::gentoo  USE="-test" 10 KiB
[ebuild  rR    ] dev-perl/HTTP-Daemon-6.10.0-r2::gentoo  19 KiB
[ebuild  rR    ] dev-perl/Error-0.170.250::gentoo  USE="-test" 32 KiB
[ebuild  rR    ] dev-perl/HTTP-Negotiate-6.10.0-r1::gentoo  9 KiB
[ebuild  rR    ] dev-perl/HTTP-Cookies-6.40.0::gentoo  USE="-test" 39 KiB
[ebuild  rR    ] dev-perl/Net-SMTP-SSL-1.40.0::gentoo  USE="-test" 3 KiB
[ebuild  r  U  ] media-gfx/graphite2-1.3.12-r1::gentoo [1.3.11::gentoo] USE="perl -test" ABI_X86="32 (64) (-x32)" 6512 KiB
[ebuild  rR    ] dev-perl/IO-Socket-INET6-2.720.0-r1::gentoo  27 KiB
[ebuild  rR    ] dev-perl/SGMLSpm-1.1-r1::gentoo  112 KiB
[ebuild  rR    ] dev-perl/Path-Class-0.370.0::gentoo  USE="-test" 37 KiB
[ebuild  rR    ] xfce-base/xfconf-4.13.5:0/3::gentoo  USE="perl -debug -test" 596 KiB
[ebuild  rR    ] dev-perl/XML-SAX-Expat-0.510.0::gentoo  USE="-test" 7 KiB
[ebuild  rR    ] dev-perl/JSON-XS-3.40.0::gentoo  USE="-examples -test" 82 KiB
[ebuild  rR    ] dev-perl/Crypt-PasswdMD5-1.400.0::gentoo  7 KiB
[ebuild  rR    ] dev-perl/XML-LibXML-2.13.200::gentoo  USE="-examples -minimal -test" 459 KiB
[ebuild  rR    ] virtual/perl-Archive-Tar-2.300.0-r1::gentoo  0 KiB
[ebuild  rR    ] dev-perl/XML-Entities-1.0.200::gentoo  USE="-minimal -test" 21 KiB
[ebuild  rR    ] dev-perl/HTML-Tree-5.70.0::gentoo  USE="-test" 147 KiB
[ebuild  rR    ] dev-perl/DBD-SQLite-1.580.0::gentoo  USE="-system-sqlite -test" 2197 KiB
[ebuild  rR    ] dev-perl/Net-UPnP-1.4.3::gentoo  USE="-examples -test" 19 KiB
[ebuild  rR    ] dev-perl/Net-HTTP-6.170.0::gentoo  USE="-minimal -test" 38 KiB
[ebuild  rR    ] dev-perl/File-DesktopEntry-0.220.0::gentoo  USE="-test" 18 KiB
[ebuild  rR    ] dev-perl/XML-Simple-2.250.0::gentoo  USE="-test" 77 KiB
[ebuild  rR    ] dev-perl/JSON-2.940.0::gentoo  USE="xs -examples -test" 81 KiB
[ebuild  rR    ] dev-perl/File-MimeInfo-0.280.0::gentoo  USE="-test" 32 KiB
[ebuild  rR    ] dev-perl/libwww-perl-6.270.0::gentoo  USE="ssl -test" 160 KiB
[ebuild  rR    ] dev-perl/LWP-Protocol-https-6.70.0::gentoo  USE="-test" 9 KiB
[ebuild  rR    ] dev-perl/XML-DOM-1.460.0-r1::gentoo  USE="-test" 115 KiB
[ebuild  rR    ] dev-perl/Crypt-SSLeay-0.720.0-r2::gentoo  USE="-libressl -test" 127 KiB
[ebuild  rR    ] dev-db/postgresql-10.5:10::gentoo  USE="kerberos nls pam perl python readline (selinux) server ssl tcl threads xml zlib -doc -ldap -libressl -static-libs (
_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 19810 KiB
[ebuild  rR    ] media-libs/ming-0.4.8-r1::gentoo  USE="perl php python -static-libs" PYTHON_TARGETS="python2_7" 14560 KiB
[ebuild  rR    ] app-editors/vim-8.1.0034::gentoo  USE="X acl lua nls perl python (selinux) tcl -cscope -debug -gpm -luajit -minimal -racket -ruby -terminal -vim-pager" PYT
N_TARGETS="python2_7 python3_4 python3_5 python3_6" 13335 KiB
[ebuild     U  ] sys-libs/tdb-1.3.16::gentoo [1.3.14::gentoo] USE="python" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 493 KiB
[ebuild  rR    ] app-text/po4a-0.54::gentoo  USE="-test" 2624 KiB
[ebuild  rR    ] app-arch/dpkg-1.19.0.5::gentoo  USE="bzip2 lzma nls (selinux) unicode update-alternatives zlib -test" 4451 KiB
[ebuild  rR    ] net-nds/openldap-2.4.45::gentoo  USE="berkdb crypt ipv6 kerberos perl samba (selinux) ssl syslog -cxx -debug -experimental -gnutls -iodbc -kinit -libressl 
atic-libs -tcpd" ABI_X86="32 (64) (-x32)" 5552 KiB
[ebuild  rR    ] dev-util/debhelper-11.3.5::gentoo  USE="-test" L10N="-de -es -fr" 457 KiB
[ebuild     U  ] sys-libs/ldb-1.3.5:0/1.3.5::gentoo [1.1.29-r1:0/1.1.29::gentoo] USE="ldap* python -doc" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 1343 KiB
[ebuild  rR    ] dev-perl/Tk-804.34.0::gentoo  USE="-examples -test" 6776 KiB
[ebuild  rR    ] dev-perl/GD-2.660.0::gentoo  USE="gif jpeg png truetype -animgif -examples -fcgi -xpm" 248 KiB
[ebuild  rR    ] app-pda/pilot-link-0.12.5-r1::gentoo  USE="bluetooth java perl png python readline threads usb -debug -static-libs" PYTHON_TARGETS="python2_7" 1550 KiB
[ebuild  rR    ] dev-perl/DBD-mysql-4.44.0::gentoo  USE="ssl -test" 152 KiB
[ebuild  rR    ] net-analyzer/net-snmp-5.8:0/35::gentoo  USE="X bzip2 ipv6 lm_sensors mfd-rewrites mysql perl python (selinux) ssl zlib -doc -elf -libressl -minimal -netlin
 KiB
[ebuild  rR    ] dev-vcs/subversion-1.10.2::gentoo  USE="apache2 berkdb extras http java nls perl python -ctypes-python -debug -doc -dso -gnome-keyring -kwallet -ruby -sasl
[ebuild     U  ] app-text/poppler-0.67.0:0/78::gentoo [0.57.0:0/68::gentoo] USE="cairo curl cxx introspection jpeg lcms nss png qt5 tiff utils -cjk -debug -doc -jpeg2k (-qt
[ebuild  rR    ] net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo  USE="graph lua perl python tcl -dbi -doc -rados -rrdcgi -ruby -static-libs -tcpd" PYTHON_SINGLE_TARGET="python3
on3_4 python3_5 python3_6%*" 2784 KiB
[ebuild  r  U  ] net-print/cups-filters-1.21.2::gentoo [1.20.4::gentoo] USE="dbus foomatic jpeg pdf perl png postscript tiff -ipp_autosetup -ldap -pclm -static-libs -test -
[ebuild  rR    ] media-gfx/graphviz-2.40.1-r1::gentoo  USE="X cairo gtk java nls pdf perl python qt5 svg tcl -devil -doc -examples -gdk-pixbuf -gts -guile -lasi -postscript
[ebuild  r  U  ] media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo [7.0.6.9:0/7.0.6.9::gentoo] USE="X bzip2 cxx djvu fontconfig graphviz jpeg lcms lzma openexr pango perl p
-jpeg2k -lqr -opencl -openmp -postscript -q32 -q8 -raw -static-libs -test -webp" 8436 KiB
[ebuild  rR    ] dev-vcs/git-2.18.0::gentoo  USE="blksha1 cgi curl gpg iconv nls pcre pcre-jit perl python subversion threads tk webdav -cvs -doc -emacs -gnome-keyring -hig
 -xinetd" PYTHON_TARGETS="python2_7" 5399 KiB
[ebuild  r  U  ] net-fs/samba-4.8.4::gentoo [4.6.7::gentoo] USE="acl addc addns client cups fam gnutls gpg ldap* pam python (selinux) syslog winbind -ads -ceph% -cluster -d
temd) -test -zeroconf" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 17286 KiB
[ebuild  rR    ] app-arch/alien-8.95-r1::gentoo  USE="bzip2" 56 KiB
[ebuild  rR    ] net-dialup/freeradius-3.0.17::gentoo  USE="kerberos mysql pam pcap python readline samba sqlite ssl -debug -firebird -iodbc -ldap -libressl -memcached -odb
[ebuild  rR    ] dev-perl/Sys-Virt-3.9.1::gentoo  USE="-examples -test" 119 KiB
[ebuild  rR    ] net-irc/kvirc-5.0_pre20180819121252::gentoo  USE="dbus dcc_video gsm nls oss perl python spell ssl theora webkit -audiofile -debug -doc -kde -phonon -profi
[ebuild  rR    ] net-libs/libproxy-0.4.13-r2::gentoo  USE="networkmanager perl python webkit -gnome -kde -mono -spidermonkey -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS=
[blocks B      ] <perl-core/Scalar-List-Utils-1.460.200_rc ("<perl-core/Scalar-List-Utils-1.460.200_rc" is blocking virtual/perl-Scalar-List-Utils-1.460.200_rc)

Total: 157 packages (21 upgrades, 136 reinstalls), Size of downloads: 220054 KiB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.26* required by (virtual/perl-Pod-Simple-3.350.0-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                
    (and 21 more with the same problem)

  (dev-lang/perl-5.24.4:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.24= required by (virtual/perl-XSLoader-0.220.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                          
    dev-lang/perl:0/5.24= required by (virtual/perl-Text-ParseWords-3.300.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.24= required by (virtual/perl-File-Spec-3.630.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                
    dev-lang/perl:0/5.24= required by (virtual/perl-IO-1.360.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.24= required by (virtual/perl-Encode-2.800.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.24= required by (virtual/perl-IO-Compress-2.69.1_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    =dev-lang/perl-5.24* required by (virtual/perl-Module-Metadata-1.0.31-r1:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                   
    dev-lang/perl:0/5.24= required by (virtual/perl-JSON-PP-2.273.0.100_rc-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                
    dev-lang/perl:0/5.24= required by (virtual/perl-libnet-3.80.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                            
    dev-lang/perl:0/5.24= required by (virtual/perl-Digest-SHA-5.950.100_rc-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.24= required by (virtual/perl-IO-Zlib-1.100.0-r10:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                          
    dev-lang/perl:0/5.24= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    dev-lang/perl:0/5.24= required by (virtual/perl-Test-Harness-3.360.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    dev-lang/perl:0/5.24= required by (virtual/perl-Storable-2.560.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    dev-lang/perl:0/5.24= required by (virtual/perl-ExtUtils-MakeMaker-7.100.200_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                         
    dev-lang/perl:0/5.24= required by (virtual/perl-MIME-Base64-3.150.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.24= required by (virtual/perl-Digest-1.170.100_rc-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.24= required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                               
    dev-lang/perl:0/5.24= required by (virtual/perl-Sys-Syslog-0.330.100_rc-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.24= required by (virtual/perl-IPC-Cmd-0.920.100_rc-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                              
    dev-lang/perl:0/5.24= required by (virtual/perl-Locale-Maketext-1.260.100_rc-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                      
    dev-lang/perl:0/5.24= required by (virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                          
    (and 27 more with the same problems)

app-text/poppler:0

  (app-text/poppler-0.67.0:0/78::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.57.0:0/68::gentoo, installed) pulled in by
    >=app-text/poppler-0.12.3-r3:0/68= required by (app-text/texlive-core-2017-r2:0/0::gentoo, installed)
                                ^^^^^^                                                                                                       
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (virtual/perl-JSON-PP-2.273.0.100_rc-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Test-Harness-3.360.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IO-1.360.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Sys-Syslog-0.330.100_rc-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-File-Spec-3.630.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-CPAN-Meta-YAML-0.18.0-r2:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Digest-SHA-5.950.100_rc-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IO-Zlib-1.100.0-r10:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-XSLoader-0.220.0-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-Manifest-1.700.0-r4:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-libnet-3.80.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-ExtUtils-MakeMaker-7.100.200_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Locale-Maketext-1.260.100_rc-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IO-Compress-2.69.1_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Encode-2.800.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Storable-2.560.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Text-ParseWords-3.300.0-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-MIME-Base64-3.150.0-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Digest-1.170.100_rc-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc-r1:0/0::gentoo, installed): ebuild is masked or unavailable
  (virtual/perl-IPC-Cmd-0.920.100_rc-r3:0/0::gentoo, installed): ebuild is masked or unavailable
  (app-text/texlive-core-2017-r2:0/0::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/Scalar-List-Utils-1.460.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Scalar-List-Utils required by @selected
    perl-core/Scalar-List-Utils:0 required by @__auto_slot_operator_replace_installed__

  (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Scalar-List-Utils required by (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/Path-Class-0.370.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by @selected
    virtual/perl-Scalar-List-Utils required by (dev-perl/DBD-SQLite-1.580.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils:0 required by @__auto_slot_operator_replace_installed__
    virtual/perl-Scalar-List-Utils required by (dev-perl/URI-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/libwww-perl-6.270.0:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-Scalar-List-Utils-1.130.0 required by (perl-core/Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/Error-0.170.250:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-perl/Crypt-SSLeay-0.720.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-python/subunit-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/List-MoreUtils-0.426.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Load-0.320.0-r6:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MIME-Charset-1.12.2:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/ming-0.4.8-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Error-0.170.250:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Sys-Virt-3.9.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TimeDate-2.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/GSSAPI-0.280.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TermReadKey-2.370.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Simple-3.350.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Package-Constants-0.60.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-LineBreak-2017.4.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/graphite2-1.3.12-r1:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Module-CoreList-5.201.806.260:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/common-sense-3.740.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/ExtUtils-PkgConfig-1.160.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/glib-perl-1.326.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV-1.950.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Base-1.90.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-RegExp-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Math-Complex-1.590.100-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libxml-perl-0.80.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-DOM-1.460.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (xfce-base/xfconf-4.13.5:0/3::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-stringy-2.111.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Encode-Locale-1.50.0:0/0::gentoo, ebuild scheduled for merge)
    (app-doc/NaturalDocs-1.52-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-XPath-1.420.0:0/0::gentoo, ebuild scheduled for merge)
    (net-libs/libproxy-0.4.13-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV_XS-1.340.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-LibXML-2.13.200:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-Protocol-https-6.70.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, ebuild scheduled for merge)
    (net-nds/openldap-2.4.45:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Archive-Tar-2.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Archive-Tar-2.300.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-DesktopEntry-0.220.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, ebuild scheduled for merge)
    (app-arch/alien-8.95-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SMTP-SSL-1.40.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/subversion-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Path-Class-0.370.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/JSON-2.940.0:0/0::gentoo, ebuild scheduled for merge)
    (app-arch/dpkg-1.19.0.5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-SQLite-1.580.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (sys-apps/texinfo-6.5:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-Balanced-2.30.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-1.260.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libintl-perl-1.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-db/postgresql-10.5:10/10::gentoo, ebuild scheduled for merge)
    (app-misc/hivex-1.3.14:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-String-1.80.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Telnet-3.40.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Constant-0.230.0-r11:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/SGMLSpm-1.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Exporter-Tiny-1.2.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MailTools-2.190.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-mysql-4.44.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Socket6-0.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-Requirements-2.140.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Log-Agent-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (app-pda/pilot-link-0.12.5-r1:0/0::gentoo, ebuild scheduled for merge)
    (app-text/po4a-0.54:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-MimeInfo-0.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libwww-perl-6.270.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/ExtUtils-Depends-0.405.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-UPnP-1.4.3:0/0::gentoo, ebuild scheduled for merge)
    (net-analyzer/net-snmp-5.8:0/35::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Daemon-6.10.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Archive-Zip-1.600.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/JSON-XS-3.40.0:0/0::gentoo, ebuild scheduled for merge)
    (app-editors/vim-8.1.0034:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/List-MoreUtils-XS-0.426.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Canary-Stability-2012.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/URI-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Locale-Maketext-Simple-0.210.100_rc-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/git-2.18.0:0/0::gentoo, ebuild scheduled for merge)
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Parser-2.440.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-util/debhelper-11.3.5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-Maketext-Lexicon-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Negotiate-6.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Simple-2.250.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Font-TTF-1.60.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Path-2.130.0:0/0::gentoo, ebuild scheduled for merge)
    (net-irc/kvirc-5.0_pre20180819121252:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Syck-1.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/String-ShellQuote-1.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Params-Check-0.380.0-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Date-Manip-6.600.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Parser-1.630.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-INET6-2.720.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/GD-2.660.0:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/exiftool-11.03:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Daemon-0.480.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/WWW-RobotRules-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-HTML-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Types-Serialiser-1.0.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (net-dialup/freeradius-3.0.17:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Cookies-6.40.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-NamespaceSupport-1.120.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Sub-Name-0.210.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/CGI-4.400.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Message-6.130.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Parser-3.720.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/PlRPC-0.202.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Path-2.130.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-HTTP-6.170.0:0/0::gentoo, ebuild scheduled for merge)
    (net-fs/samba-4.8.4:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-Unidecode-1.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-CoreList-5.201.806.260:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Load-Conditional-0.680.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Entities-1.0.200:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Scalar-List-Utils-1.460.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-if-0.60.600-r2:0/0::gentoo, ebuild scheduled for merge)
    (net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo, ebuild scheduled for merge)
    (dev-perl/Tk-804.34.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Try-Tiny-0.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-BaseDir-0.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Expat-0.510.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBI-1.637.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
  (app-text/poppler-0.67.0:0/78::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)
  (app-text/qpdf-8.1.0:0/21::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-fs/samba-4.8.4::gentoo
# required by net-dialup/freeradius-3.0.17::gentoo[samba]
# required by @selected
# required by @world (argument)
=sys-libs/ldb-1.3.5 ldap

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

As you can see “136 reinstalls”, because all perl modules must be rebuild/reinstalled with the new perl.

So the first problem is:

  (dev-lang/perl-5.24.4:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.24= required by (virtual/perl-XSLoader-0.220.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                          
    dev-lang/perl:0/5.24= required by (virtual/perl-Text-ParseWords-3.300.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.24= required by (virtual/perl-File-Spec-3.630.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                
    dev-lang/perl:0/5.24= required by (virtual/perl-IO-1.360.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.24= required by (virtual/perl-Encode-2.800.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.24= required by (virtual/perl-IO-Compress-2.69.1_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^   
.....
.....
  (app-text/poppler-0.67.0:0/78::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.57.0:0/68::gentoo, installed) pulled in by
    >=app-text/poppler-0.12.3-r3:0/68= required by (app-text/texlive-core-2017-r2:0/0::gentoo, installed)
                                ^^^^^^                                                                                                       
    (and 1 more with the same problem)
.....
.....

So many packages want perl 5.24 and not the update perl 5.26, so we add them explicitly to the emerge command line and the best way is to use qlist like this:

$(qlist -IC|grep perl|sort|uniq)

which will output all the packages with perl in their names. At the end we want to rebuild/reinstall all perl modules, so it seems a good idea to just explicitly include them.
There is a USE flag requirement, too:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-fs/samba-4.8.4::gentoo
# required by net-dialup/freeradius-3.0.17::gentoo[samba]
# required by @selected
# required by @world (argument)
=sys-libs/ldb-1.3.5 ldap

So you must add this USE flag in package.use directory in /etc/portage/package.use/mybase (or whatever is the name of your package use files) – if you do not have one, just add a file with this name:

root@srv ~ # echo "sys-libs/ldb ldap" >> /etc/portage/package.use/mybase

We add “app-text/poppler”,too and also verbose options for more information about the blocked package. Because there are so many reinstalls why not to just drop the “-u” update argument, it should be easier for the emerge:

root@srv ~ # emerge --verbose --verbose-conflicts --backtrack=200000 $(qlist -IC|grep perl|sort|uniq) app-text/poppler                                
 
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-python/hyperlink-18.0.0::gentoo  USE="-test" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -python3_7" 96 KiB
[ebuild  r  U  ] dev-lang/perl-5.26.2:0/5.26::gentoo [5.24.1-r2:0/5.24::gentoo] USE="berkdb gdbm ithreads -debug -doc" 11770 KiB
[ebuild     U  ] virtual/perl-Carp-1.420.0::gentoo [1.400.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-File-Spec-3.670.0::gentoo [3.630.100_rc-r1::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-Exporter-5.720.0-r3::gentoo  0 KiB
[ebuild     U  ] virtual/perl-Encode-2.880.0::gentoo [2.800.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IO-1.380.0::gentoo [1.360.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Scalar-List-Utils-1.460.200_rc::gentoo [1.460.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Data-Dumper-2.167.0::gentoo [2.160.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-MIME-Base64-3.150.0-r4::gentoo [3.150.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Storable-2.620.0::gentoo [2.560.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-libnet-3.100.0::gentoo [3.80.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Compress-Raw-Zlib-2.74.0::gentoo [2.69.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-XSLoader-0.270.0::gentoo [0.220.0-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo  19 KiB
[ebuild     U  ] virtual/perl-Time-Local-1.250.0-r1::gentoo [1.230.0-r6::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-parent-0.236.0-r1::gentoo [0.234.0-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/HTML-Tagset-3.200.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/TimeDate-2.300.0::gentoo  31 KiB
[ebuild     U  ] virtual/perl-Digest-MD5-2.550.0::gentoo [2.540.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.380.0::gentoo [3.360.100_rc-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/GSSAPI-0.280.0-r1::gentoo  USE="-test" 67 KiB
[ebuild   R    ] dev-perl/Net-Daemon-0.480.0-r2::gentoo  29 KiB
[ebuild   R    ] dev-perl/Socket6-0.280.0::gentoo  65 KiB
[ebuild   R    ] perl-core/File-Path-2.130.0::gentoo  31 KiB
[ebuild   R    ] perl-core/File-Temp-0.230.400-r1::gentoo  59 KiB
[ebuild     U  ] virtual/perl-Compress-Raw-Bzip2-2.74.0-r1::gentoo [2.69.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Digest-SHA-5.960.0::gentoo [5.950.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IO-Socket-IP-0.380.0::gentoo [0.370.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Sys-Syslog-0.350.0-r1::gentoo [0.330.100_rc-r3::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-if-0.60.600-r2::gentoo  0 KiB
[ebuild  rR    ] dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7%" 450 KiB
[ebuild     U  ] app-text/qpdf-8.1.0:0/21::gentoo [7.0.0:0/18::gentoo] USE="perl -doc -examples -static-libs -test" 8051 KiB
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-7.240.0::gentoo [7.100.200_rc-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/XML-Parser-2.440.0::gentoo  232 KiB
[ebuild     U  ] virtual/perl-Getopt-Long-2.490.0::gentoo [2.480.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r3::gentoo [0.18.0-r2::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-CBuilder-0.280.225-r2::gentoo  0 KiB
[ebuild     U  ] virtual/perl-JSON-PP-2.274.0.200_rc::gentoo [2.273.0.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-2.150.10-r1::gentoo [1.441.700.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Perl-OSType-1.10.0-r1::gentoo [1.9.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-version-0.991.700::gentoo [0.991.600-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/IO-String-1.80.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/Text-CharWidth-0.40.0-r1::gentoo  9 KiB
[ebuild   R    ] perl-core/Module-CoreList-5.201.806.260::gentoo  103 KiB
[ebuild     U  ] virtual/perl-Digest-1.170.100_rc-r7::gentoo [1.170.100_rc-r3::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-Constant-0.230.0-r11::gentoo  0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-Install-2.40.0-r3::gentoo  0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.700.0-r5::gentoo [1.700.0-r4::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.340.0::gentoo [3.310.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IO-Zlib-1.100.0-r11::gentoo [1.100.0-r10::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IPC-Cmd-0.960.0::gentoo [0.920.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Locale-Maketext-1.280.0::gentoo [1.260.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Metadata-1.0.33-r1::gentoo [1.0.31-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Text-ParseWords-3.300.0-r4::gentoo [3.300.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-podlators-4.90.0::gentoo [4.70.0-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/Package-Constants-0.60.0::gentoo  4 KiB
[ebuild   R    ] dev-perl/String-ShellQuote-1.40.0-r1::gentoo  7 KiB
[ebuild   R    ] dev-perl/YAML-Syck-1.300.0::gentoo  167 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-Requirements-2.140.0-r3::gentoo [2.140.0-r2::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Locale-Maketext-Simple-0.210.100_rc-r7::gentoo [0.210.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Math-Complex-1.590.100-r1::gentoo [1.590.0-r9::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Load-0.320.0-r6::gentoo [0.320.0-r5::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Load-Conditional-0.680.0-r1::gentoo [0.640.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Params-Check-0.380.0-r7::gentoo [0.380.0-r6::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Pod-Parser-1.630.0-r4::gentoo [1.630.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Pod-Simple-3.350.0-r1::gentoo [3.320.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Text-Balanced-2.30.0-r4::gentoo [2.30.0-r3::gentoo] 0 KiB
[ebuild  rR    ] media-libs/exiftool-11.03::gentoo  USE="-doc" 4311 KiB
[ebuild  rR    ] app-doc/NaturalDocs-1.52-r1::gentoo  450 KiB
[ebuild   R    ] dev-perl/URI-1.730.0::gentoo  USE="-test" 105 KiB
[ebuild   R    ] virtual/perl-File-Temp-0.230.400-r5::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTTP-Date-6.20.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/HTML-Parser-3.720.0::gentoo  USE="-test" 89 KiB
[ebuild   R    ] virtual/perl-File-Path-2.130.0::gentoo  0 KiB
[ebuild     U  ] virtual/perl-IO-Compress-2.74.0-r1::gentoo [2.69.1_rc-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/TermReadKey-2.370.0::gentoo  USE="-examples" 84 KiB
[ebuild   R    ] dev-perl/Encode-Locale-1.50.0::gentoo  USE="-test" 9 KiB
[ebuild   R    ] dev-perl/Digest-HMAC-1.30.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/IO-HTML-1.1.0::gentoo  USE="-test" 19 KiB
[ebuild   R    ] dev-perl/IPC-System-Simple-1.250.0::gentoo  USE="-test" 30 KiB
[ebuild   R    ] dev-perl/MailTools-2.190.0::gentoo  USE="-examples -test" 55 KiB
[ebuild   R    ] dev-perl/Net-SSLeay-1.820.0::gentoo  USE="-examples -libressl -minimal -test" 390 KiB
[ebuild   R    ] dev-perl/PlRPC-0.202.0-r3::gentoo  18 KiB
[ebuild   R    ] dev-perl/Sub-Name-0.210.0::gentoo  USE="-suggested -test" 80 KiB
[ebuild   R    ] dev-perl/Text-Unidecode-1.300.0::gentoo  135 KiB
[ebuild   R    ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo  31 KiB
[ebuild   R    ] dev-perl/libintl-perl-1.280.0::gentoo  460 KiB
[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.120.0::gentoo  USE="-test" 18 KiB
[ebuild   R    ] dev-perl/ExtUtils-PkgConfig-1.160.0::gentoo  10 KiB
[ebuild   R    ] dev-perl/ExtUtils-Depends-0.405.0::gentoo  USE="-test" 18 KiB
[ebuild   R    ] dev-perl/Locale-gettext-1.70.0::gentoo  9 KiB
[ebuild   R    ] dev-perl/XML-SAX-Base-1.90.0::gentoo  USE="-test" 28 KiB
[ebuild   R    ] dev-perl/common-sense-3.740.0-r1::gentoo  13 KiB
[ebuild   R    ] dev-perl/Canary-Stability-2012.0.0::gentoo  5 KiB
[ebuild   R    ] dev-perl/Exporter-Tiny-1.2.1::gentoo  USE="-examples -test" 32 KiB
[ebuild   R    ] dev-perl/IO-stringy-2.111.0::gentoo  41 KiB
[ebuild   R    ] dev-perl/Locale-Maketext-Lexicon-1.0.0::gentoo  USE="-test" 90 KiB
[ebuild   R    ] dev-perl/Log-Agent-1.1.0::gentoo  USE="-test" 55 KiB
[ebuild   R    ] dev-perl/MIME-Charset-1.12.2::gentoo  L10N="-ja -zh" 55 KiB
[ebuild   R    ] dev-perl/Text-CSV_XS-1.340.0::gentoo  USE="-examples -test" 170 KiB
[ebuild   R    ] dev-perl/Text-WrapI18N-0.60.0-r1::gentoo  4 KiB
[ebuild   R    ] dev-perl/XML-RegExp-0.40.0-r1::gentoo  4 KiB
[ebuild   R    ] dev-perl/XML-XPath-1.420.0::gentoo  USE="-examples -test" 55 KiB
[ebuild   R    ] dev-perl/YAML-Tiny-1.730.0::gentoo  USE="-minimal -test" 72 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.150.10-r1::gentoo [2.150.5-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/Date-Manip-6.600.0::gentoo  USE="-test" 1783 KiB
[ebuild   R    ] dev-perl/Digest-SHA1-2.130.0-r1::gentoo  39 KiB
[ebuild   R    ] dev-perl/Net-Telnet-3.40.0::gentoo  40 KiB
[ebuild   R    ] dev-perl/YAML-1.260.0::gentoo  USE="-test" 85 KiB
[ebuild   R    ] dev-perl/libxml-perl-0.80.0-r2::gentoo  63 KiB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.460.0::gentoo  USE="-test" 0 KiB
[ebuild   R    ] virtual/perl-Module-CoreList-5.201.806.260::gentoo  0 KiB
[ebuild  rR    ] sys-apps/texinfo-6.5::gentoo  USE="nls -static" 4398 KiB
[ebuild   R    ] dev-perl/HTTP-Message-6.130.0::gentoo  USE="-test" 73 KiB
[ebuild   R    ] dev-perl/IO-Socket-SSL-2.52.0::gentoo  USE="-examples -idn" 217 KiB
[ebuild   R    ] dev-perl/DBI-1.637.0::gentoo  USE="-examples -test" 583 KiB
[ebuild   R    ] dev-perl/Try-Tiny-0.300.0::gentoo  USE="-minimal -test" 34 KiB
[ebuild   R    ] dev-perl/Authen-SASL-2.160.0-r1::gentoo  USE="kerberos" 45 KiB
[ebuild   R    ] dev-perl/CGI-4.400.0::gentoo  USE="-examples -test" 196 KiB
[ebuild   R    ] dev-perl/File-Listing-6.40.0-r1::gentoo  51 KiB
[ebuild   R    ] dev-perl/WWW-RobotRules-6.20.0-r1::gentoo  9 KiB
[ebuild   R    ] dev-perl/Module-Build-0.422.400::gentoo  USE="-test" 298 KiB
[ebuild   R    ] dev-perl/XML-SAX-1.0.0::gentoo  46 KiB
[ebuild   R    ] dev-perl/List-MoreUtils-XS-0.426.0::gentoo  USE="-test" 156 KiB
[ebuild   R    ] dev-perl/Types-Serialiser-1.0.0-r1::gentoo  7 KiB
[ebuild   R    ] dev-perl/Unicode-LineBreak-2017.4.0-r1::gentoo  305 KiB
[ebuild   R    ] dev-perl/glib-perl-1.326.0::gentoo  291 KiB
[ebuild   R    ] perl-core/Archive-Tar-2.300.0::gentoo  USE="-test" 63 KiB
[ebuild   R    ] perl-core/Test-Simple-1.302.96::gentoo  USE="-examples" 276 KiB
[ebuild   R    ] dev-perl/Archive-Zip-1.600.0-r1::gentoo  USE="-examples -test" 187 KiB
[ebuild   R    ] dev-perl/Font-TTF-1.60.0::gentoo  251 KiB
[ebuild   R    ] dev-perl/Text-CSV-1.950.0::gentoo  USE="xs -test" 112 KiB
[ebuild  rR    ] app-misc/hivex-1.3.14::gentoo  USE="perl python readline -ocaml -ruby -static-libs -test" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6*" RUBY_TARGETS="ruby23 ruby24%* -ruby25% (-ruby22%)" 1302 KiB
[ebuild   R    ] dev-perl/File-BaseDir-0.70.0::gentoo  USE="-test" 10 KiB
[ebuild   R    ] dev-perl/Error-0.170.250::gentoo  USE="-test" 32 KiB
[ebuild   R    ] dev-perl/HTTP-Cookies-6.40.0::gentoo  USE="-test" 39 KiB
[ebuild   R    ] dev-perl/HTTP-Daemon-6.10.0-r2::gentoo  19 KiB
[ebuild   R    ] dev-perl/HTTP-Negotiate-6.10.0-r1::gentoo  9 KiB
[ebuild   R    ] dev-perl/IO-Socket-INET6-2.720.0-r1::gentoo  27 KiB
[ebuild   R    ] dev-perl/Net-SMTP-SSL-1.40.0::gentoo  USE="-test" 3 KiB
[ebuild  r  U  ] media-gfx/graphite2-1.3.12-r1::gentoo [1.3.11::gentoo] USE="perl -test" ABI_X86="32 (64) (-x32)" 6512 KiB
[ebuild   R    ] dev-perl/SGMLSpm-1.1-r1::gentoo  112 KiB
[ebuild   R    ] dev-perl/JSON-XS-3.40.0::gentoo  USE="-examples -test" 82 KiB
[ebuild   R    ] dev-perl/Path-Class-0.370.0::gentoo  USE="-test" 37 KiB
[ebuild   R    ] dev-perl/XML-SAX-Expat-0.510.0::gentoo  USE="-test" 7 KiB
[ebuild  rR    ] xfce-base/xfconf-4.13.5:0/3::gentoo  USE="perl -debug -test" 596 KiB
[ebuild   R    ] dev-perl/Crypt-PasswdMD5-1.400.0::gentoo  7 KiB
[ebuild   R    ] dev-perl/DBD-SQLite-1.580.0::gentoo  USE="-system-sqlite -test" 2197 KiB
[ebuild   R    ] dev-perl/HTML-Tree-5.70.0::gentoo  USE="-test" 147 KiB
[ebuild   R    ] dev-perl/List-MoreUtils-0.426.0::gentoo  USE="xs -test" 143 KiB
[ebuild   R    ] dev-perl/Net-UPnP-1.4.3::gentoo  USE="-examples -test" 19 KiB
[ebuild   R    ] dev-perl/XML-Entities-1.0.200::gentoo  USE="-minimal -test" 21 KiB
[ebuild   R    ] dev-perl/XML-LibXML-2.13.200::gentoo  USE="-examples -minimal -test" 459 KiB
[ebuild   R    ] virtual/perl-Archive-Tar-2.300.0-r1::gentoo  0 KiB
[ebuild   R    ] virtual/perl-Test-Simple-1.302.96::gentoo  0 KiB
[ebuild   R    ] dev-perl/Net-HTTP-6.170.0::gentoo  USE="-minimal -test" 38 KiB
[ebuild   R    ] dev-perl/File-DesktopEntry-0.220.0::gentoo  USE="-test" 18 KiB
[ebuild   R    ] dev-perl/JSON-2.940.0::gentoo  USE="xs -examples -test" 81 KiB
[ebuild   R    ] dev-perl/XML-Simple-2.250.0::gentoo  USE="-test" 77 KiB
[ebuild   R    ] dev-perl/File-MimeInfo-0.280.0::gentoo  USE="-test" 32 KiB
[ebuild   R    ] dev-perl/libwww-perl-6.270.0::gentoo  USE="ssl -test" 160 KiB
[ebuild   R    ] dev-perl/LWP-Protocol-https-6.70.0::gentoo  USE="-test" 9 KiB
[ebuild   R    ] dev-perl/XML-DOM-1.460.0-r1::gentoo  USE="-test" 115 KiB
[ebuild   R    ] dev-perl/Crypt-SSLeay-0.720.0-r2::gentoo  USE="-libressl -test" 127 KiB
[ebuild  rR    ] dev-db/postgresql-10.5:10::gentoo  USE="kerberos nls pam perl python readline (selinux) server ssl tcl threads xml zlib -doc -ldap -libressl -static-libs (-systemd) -uuid" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 19810 KiB
[ebuild  rR    ] media-libs/ming-0.4.8-r1::gentoo  USE="perl php python -static-libs" PYTHON_TARGETS="python2_7" 14560 KiB
[ebuild  rR    ] app-editors/vim-8.1.0034::gentoo  USE="X acl lua nls perl python (selinux) tcl -cscope -debug -gpm -luajit -minimal -racket -ruby -terminal -vim-pager" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 13335 KiB
[ebuild     U  ] sys-libs/tdb-1.3.16::gentoo [1.3.14::gentoo] USE="python" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 493 KiB
[ebuild  rR    ] app-text/po4a-0.54::gentoo  USE="-test" 2624 KiB
[ebuild  rR    ] app-arch/dpkg-1.19.0.5::gentoo  USE="bzip2 lzma nls (selinux) unicode update-alternatives zlib -test" 4451 KiB
[ebuild  rR    ] net-nds/openldap-2.4.45::gentoo  USE="berkdb crypt ipv6 kerberos perl samba (selinux) ssl syslog -cxx -debug -experimental -gnutls -iodbc -kinit -libressl -minimal -odbc -overlays -pbkdf2 -sasl -sha2 -slp -smbkrb5passwd -static-libs -tcpd" ABI_X86="32 (64) (-x32)" 5552 KiB
[ebuild  rR    ] dev-util/debhelper-11.3.5::gentoo  USE="-test" L10N="-de -es -fr" 457 KiB
[ebuild     U  ] sys-libs/ldb-1.3.5:0/1.3.5::gentoo [1.1.29-r1:0/1.1.29::gentoo] USE="ldap* python -doc" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 1343 KiB
[ebuild   R    ] dev-perl/Tk-804.34.0::gentoo  USE="-examples -test" 6776 KiB
[ebuild   R    ] dev-perl/GD-2.660.0::gentoo  USE="gif jpeg png truetype -animgif -examples -fcgi -xpm" 248 KiB
[ebuild  rR    ] app-pda/pilot-link-0.12.5-r1::gentoo  USE="bluetooth java perl png python readline threads usb -debug -static-libs" PYTHON_TARGETS="python2_7" 1550 KiB
[ebuild   R    ] dev-perl/DBD-mysql-4.44.0::gentoo  USE="ssl -test" 152 KiB
[ebuild  rR    ] net-analyzer/net-snmp-5.8:0/35::gentoo  USE="X bzip2 ipv6 lm_sensors mfd-rewrites mysql perl python (selinux) ssl zlib -doc -elf -libressl -minimal -netlink -pci -rpm -smux -tcpd -ucd-compat" PYTHON_TARGETS="python2_7" 6441 KiB
[ebuild  rR    ] dev-vcs/subversion-1.10.2::gentoo  USE="apache2 berkdb extras http java nls perl python -ctypes-python -debug -doc -dso -gnome-keyring -kwallet -ruby -sasl -test -vim-syntax" PYTHON_TARGETS="python2_7" 8177 KiB
[ebuild  r  U  ] app-text/poppler-0.67.0:0/78::gentoo [0.57.0:0/68::gentoo] USE="cairo curl cxx introspection jpeg lcms nss png qt5 tiff utils -cjk -debug -doc -jpeg2k (-qt4%*)" 1426 KiB
[ebuild  rR    ] net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo  USE="graph lua perl python tcl -dbi -doc -rados -rrdcgi -ruby -static-libs -tcpd" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6%" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6%*" 2784 KiB
[ebuild  r  U  ] net-print/cups-filters-1.21.2::gentoo [1.20.4::gentoo] USE="dbus foomatic jpeg pdf perl png postscript tiff -ipp_autosetup -ldap -pclm -static-libs -test -zeroconf" 1439 KiB
[ebuild  rR    ] media-gfx/graphviz-2.40.1-r1::gentoo  USE="X cairo gtk java nls pdf perl python qt5 svg tcl -devil -doc -examples -gdk-pixbuf -gts -guile -lasi -postscript -ruby -static-libs" PYTHON_TARGETS="python2_7" 25033 KiB
[ebuild  r  U  ] media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo [7.0.6.9:0/7.0.6.9::gentoo] USE="X bzip2 cxx djvu fontconfig graphviz jpeg lcms lzma openexr pango perl png svg tiff truetype wmf xml zlib -corefonts -fftw -fpx -hdri -jbig -jpeg2k -lqr -opencl -openmp -postscript -q32 -q8 -raw -static-libs -test -webp" 8436 KiB
[ebuild  rR    ] dev-vcs/git-2.18.0::gentoo  USE="blksha1 cgi curl gpg iconv nls pcre pcre-jit perl python subversion threads tk webdav -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -test -xinetd" PYTHON_TARGETS="python2_7" 5399 KiB
[ebuild  rR    ] media-gfx/uniconvertor-2.0_pre379-r2::gentoo  PYTHON_TARGETS="python2_7" 1802 KiB
[ebuild  r  U  ] app-editors/emacs-vcs-27.0.50_pre20180831:27::gentoo [27.0.50_pre20180731:27::gentoo] USE="X acl alsa dbus gif gmp%* gtk imagemagick inotify jpeg json kerberos lcms png (selinux) sound ssl svg threads tiff xpm zlib -Xaw3d (-aqua) -athena (-cairo) -dynamic-loading -games -gconf -gfile -gpm -gsettings -gtk2 -gzip-el -libxml2 -livecd -m17n-lib -mailutils -motif -source (-systemd) -toolkit-scroll-bars -wide-int -xft -xwidgets" 27997 KiB
[ebuild  rR    ] dev-php/pecl-imagick-3.4.3::gentoo  USE="-examples -test" PHP_TARGETS="php5-6 php7-0 php7-1 -php7-2%" 240 KiB
[ebuild  rR    ] media-video/dvdauthor-0.7.2-r2::gentoo  USE="imagemagick -graphicsmagick" 634 KiB
[ebuild  r  U  ] net-fs/samba-4.8.4::gentoo [4.6.7::gentoo] USE="acl addc addns client cups fam gnutls gpg ldap* pam python (selinux) syslog winbind -ads -ceph% -cluster -debug (-dmapi) -iprint -quota (-system-heimdal) -system-mitkrb5 (-systemd) -test -zeroconf" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 17286 KiB
[ebuild  rR    ] app-arch/alien-8.95-r1::gentoo  USE="bzip2" 56 KiB
[ebuild  rR    ] media-gfx/inkscape-0.92.3::gentoo  USE="dbus exif imagemagick jpeg lcms nls openmp spell -cdr -dia -gnome -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 30866 KiB
[ebuild   R    ] app-admin/perl-cleaner-2.26-r1::gentoo  8 KiB
[ebuild  rR    ] net-dialup/freeradius-3.0.17::gentoo  USE="kerberos mysql pam pcap python readline samba sqlite ssl -debug -firebird -iodbc -ldap -libressl -memcached -odbc -oracle -postgres -rest" PYTHON_TARGETS="python2_7" 4730 KiB
[ebuild  r  U  ] app-text/texlive-core-2017-r4::gentoo [2017-r2::gentoo] USE="X luajittex tk -cjk -doc -source -xetex" 73174 KiB
[ebuild   R    ] dev-perl/Sys-Virt-3.9.1::gentoo  USE="-examples -test" 119 KiB
[ebuild  rR    ] net-irc/kvirc-5.0_pre20180819121252::gentoo  USE="dbus dcc_video gsm nls oss perl python spell ssl theora webkit -audiofile -debug -doc -kde -phonon -profile" PYTHON_TARGETS="python2_7" 5908 KiB
[ebuild  rR    ] net-libs/libproxy-0.4.13-r2::gentoo  USE="networkmanager perl python webkit -gnome -kde -mono -spidermonkey -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 88 KiB
[blocks B      ] <perl-core/Scalar-List-Utils-1.460.200_rc ("<perl-core/Scalar-List-Utils-1.460.200_rc" is blocking virtual/perl-Scalar-List-Utils-1.460.200_rc)

Total: 199 packages (57 upgrades, 142 reinstalls), Size of downloads: 343533 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/Scalar-List-Utils-1.460.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Scalar-List-Utils required by @selected
    perl-core/Scalar-List-Utils

  (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Scalar-List-Utils required by @selected
    virtual/perl-Scalar-List-Utils required by (dev-perl/Path-Class-0.370.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/URI-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/libwww-perl-6.270.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils
    virtual/perl-Scalar-List-Utils required by (dev-perl/Error-0.170.250:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-Scalar-List-Utils-1.130.0 required by (perl-core/Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/DBD-SQLite-1.580.0:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (virtual/perl-File-Path-2.130.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-HTML-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-Zlib-1.100.0-r11:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/git-2.18.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Package-Constants-0.60.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Negotiate-6.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Archive-Tar-2.300.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/common-sense-3.740.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-Protocol-https-6.70.0:0/0::gentoo, ebuild scheduled for merge)
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)
    (net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo, ebuild scheduled for merge)
    (app-arch/alien-8.95-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-LineBreak-2017.4.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Expat-0.510.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/ExtUtils-PkgConfig-1.160.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Canary-Stability-2012.0.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (dev-python/subunit-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/WWW-RobotRules-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (app-text/po4a-0.54:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MIME-Charset-1.12.2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Path-Class-0.370.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TimeDate-2.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Digest-SHA-5.960.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-MIME-Base64-3.150.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV_XS-1.340.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-DOM-1.460.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/URI-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-util/debhelper-11.3.5:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/graphite2-1.3.12-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/String-ShellQuote-1.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Tk-804.34.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-1.260.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Digest-1.170.100_rc-r7:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Module-CoreList-5.201.806.260:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/CGI-4.400.0:0/0::gentoo, ebuild scheduled for merge)
    (net-libs/libproxy-0.4.13-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-editors/vim-8.1.0034:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Storable-2.620.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/JSON-XS-3.40.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Date-Manip-6.600.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-BaseDir-0.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-Unidecode-1.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-parent-0.236.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Carp-1.420.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Base-1.90.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/List-MoreUtils-0.426.0:0/0::gentoo, ebuild scheduled for merge)
    (xfce-base/xfconf-4.13.5:0/3::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-NamespaceSupport-1.120.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-mysql-4.44.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-HTTP-6.170.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Error-0.170.250:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-CoreList-5.201.806.260:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Syck-1.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Exporter-Tiny-1.2.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/ExtUtils-Depends-0.405.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/exiftool-11.03:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    (net-dialup/freeradius-3.0.17:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MailTools-2.190.0:0/0::gentoo, ebuild scheduled for merge)
    (net-fs/samba-4.8.4:0/0::gentoo, ebuild scheduled for merge)
    (net-analyzer/net-snmp-5.8:0/35::gentoo, ebuild scheduled for merge)
    (virtual/perl-Locale-Maketext-Simple-0.210.100_rc-r7:0/0::gentoo, ebuild scheduled for merge)
    (sys-apps/texinfo-6.5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-String-1.80.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-XPath-1.420.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SMTP-SSL-1.40.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-Compress-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Daemon-6.10.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/JSON-2.940.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-RegExp-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-UPnP-1.4.3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-DesktopEntry-0.220.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV-1.950.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Entities-1.0.200:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IPC-Cmd-0.960.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Parser-2.440.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Archive-Zip-1.600.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Constant-0.230.0-r11:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/ming-0.4.8-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Encode-2.880.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TermReadKey-2.370.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Try-Tiny-0.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Load-0.320.0-r6:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-Requirements-2.140.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-Socket-IP-0.380.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libwww-perl-6.270.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-1.380.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBI-1.637.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Daemon-0.480.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Encode-Locale-1.50.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-INET6-2.720.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (net-irc/kvirc-5.0_pre20180819121252:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/glib-perl-1.326.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-Balanced-2.30.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Time-Local-1.250.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Scalar-List-Utils-1.460.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-Maketext-Lexicon-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-MimeInfo-0.280.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-libnet-3.100.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Perl-OSType-1.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/subversion-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Path-2.130.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-if-0.60.600-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Crypt-SSLeay-0.720.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-doc/NaturalDocs-1.52-r1:0/0::gentoo, ebuild scheduled for merge)
    (app-arch/dpkg-1.19.0.5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Sys-Virt-3.9.1:0/0::gentoo, ebuild scheduled for merge)
    (app-misc/hivex-1.3.14:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Socket6-0.280.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Simple-3.350.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Load-Conditional-0.680.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Cookies-6.40.0:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo, ebuild scheduled for merge)
    (dev-perl/libintl-perl-1.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Font-TTF-1.60.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Sub-Name-0.210.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/PlRPC-0.202.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-db/postgresql-10.5:10/10::gentoo, ebuild scheduled for merge)
    (virtual/perl-Params-Check-0.380.0-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-stringy-2.111.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Data-Dumper-2.167.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Log-Agent-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/GSSAPI-0.280.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-podlators-4.90.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-XSLoader-0.270.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-version-0.991.700:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/List-MoreUtils-XS-0.426.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libxml-perl-0.80.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-pda/pilot-link-0.12.5-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Math-Complex-1.590.100-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Types-Serialiser-1.0.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::gentoo, ebuild scheduled for merge)
    (net-nds/openldap-2.4.45:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Parser-3.720.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Sys-Syslog-0.350.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Telnet-3.40.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-MakeMaker-7.240.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-SQLite-1.580.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Getopt-Long-2.490.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/GD-2.660.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Metadata-1.0.33-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Spec-3.670.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Locale-Maketext-1.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Digest-MD5-2.550.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/SGMLSpm-1.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Message-6.130.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Archive-Tar-2.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Parser-1.630.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-LibXML-2.13.200:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Simple-2.250.0:0/0::gentoo, ebuild scheduled for merge)
  (app-text/poppler-0.67.0:0/78::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)
    (app-text/texlive-core-2017-r4:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/inkscape-0.92.3:0/0::gentoo, ebuild scheduled for merge)
  (media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-gfx/uniconvertor-2.0_pre379-r2:0/0::gentoo, ebuild scheduled for merge)
    (media-video/dvdauthor-0.7.2-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-editors/emacs-vcs-27.0.50_pre20180831:27/27::gentoo, ebuild scheduled for merge)
    (media-gfx/inkscape-0.92.3:0/0::gentoo, ebuild scheduled for merge)
    (dev-php/pecl-imagick-3.4.3:0/0::gentoo, ebuild scheduled for merge)
  (app-text/qpdf-8.1.0:0/21::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)

As you can see again we have this strange block:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/Scalar-List-Utils-1.460.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Scalar-List-Utils required by @selected
    perl-core/Scalar-List-Utils

  (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Scalar-List-Utils required by @selected
    virtual/perl-Scalar-List-Utils required by (dev-perl/Path-Class-0.370.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/URI-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/libwww-perl-6.270.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils
    virtual/perl-Scalar-List-Utils required by (dev-perl/Error-0.170.250:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-Scalar-List-Utils-1.130.0 required by (perl-core/Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-Scalar-List-Utils required by (dev-perl/DBD-SQLite-1.580.0:0/0::gentoo, ebuild scheduled for merge)

“virtual/perl-Scalar-List-Utils-1.460.200_rc” and “perl-core/Scalar-List-Utils-1.460.0” are selected by our emerge command line “$(qlist -IC|grep perl|sort|uniq)” – all packages with perl names and apparently emerge pulls the updated version of the virtual package “virtual/perl-Scalar-List-Utils” (“virtual/perl-Scalar-List-Utils-1.460.200_rc”) , which is not compatible with selected “perl-core/Scalar-List-Utils-1.460.0” – because there is no dependency limitations in the emerge output for “perl-core/Scalar-List-Utils” – probably this is the most recent version for the perl 5.26 package, so there should be a virtual package compliant with our “perl-core/Scalar-List-Utils” and perl 5.26 update. You could guess the name: “virtual/perl-Scalar-List-Utils-1.460.0” and

we must add it to the emerge arguments

. Check the directory of your portage and look for the file:

root@srv ~ # ls -altr /usr/portage/virtual/perl-Scalar-List-Utils/
total 40
-rw-r--r--.   1 portage portage   257 25 Jan  2016 metadata.xml
-rw-r--r--.   1 portage portage   639 31 Aug  2,40 perl-Scalar-List-Utils-1.500.0.ebuild
-rw-r--r--.   1 portage portage   639 31 Aug  2,40 perl-Scalar-List-Utils-1.460.200_rc.ebuild
-rw-r--r--.   1 portage portage   544 31 Aug  2,40 perl-Scalar-List-Utils-1.460.0-r1.ebuild
-rw-r--r--.   1 portage portage   626 31 Aug  2,40 perl-Scalar-List-Utils-1.420.200_rc-r1.ebuild
-rw-r--r--.   1 portage portage  1599 31 Aug  2,40 Manifest
drwxr-xr-x.   2 portage portage  4096  1 Sep 10,12 .
drwxr-xr-x. 204 portage portage 12288  4 Sep 15,20 ..

As you can see the file is “perl-Scalar-List-Utils-1.460.0-r1.ebuild” and here is the emerge command line, which will begin updating our perl to 5.26:

root@srv ~ # emerge --verbose --verbose-conflicts --backtrack=200000 $(qlist -IC|grep perl|sort|uniq) app-text/poppler =perl-Scalar-List-Utils-1.460.0-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-python/hyperlink-18.0.0::gentoo  USE="-test" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -python3_7" 96 KiB
[ebuild  r  U  ] dev-lang/perl-5.26.2:0/5.26::gentoo [5.24.1-r2:0/5.24::gentoo] USE="berkdb gdbm ithreads -debug -doc" 11770 KiB
[ebuild     U  ] virtual/perl-Carp-1.420.0::gentoo [1.400.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-File-Spec-3.670.0::gentoo [3.630.100_rc-r1::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-Exporter-5.720.0-r3::gentoo  0 KiB
[ebuild     U  ] virtual/perl-Encode-2.880.0::gentoo [2.800.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IO-1.380.0::gentoo [1.360.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Data-Dumper-2.167.0::gentoo [2.160.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-MIME-Base64-3.150.0-r4::gentoo [3.150.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Storable-2.620.0::gentoo [2.560.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-libnet-3.100.0::gentoo [3.80.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Compress-Raw-Zlib-2.74.0::gentoo [2.69.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-XSLoader-0.270.0::gentoo [0.220.0-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo  19 KiB
[ebuild     U  ] virtual/perl-Time-Local-1.250.0-r1::gentoo [1.230.0-r6::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-parent-0.236.0-r1::gentoo [0.234.0-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/HTML-Tagset-3.200.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/TimeDate-2.300.0::gentoo  31 KiB
[ebuild     U  ] virtual/perl-Digest-MD5-2.550.0::gentoo [2.540.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.380.0::gentoo [3.360.100_rc-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/GSSAPI-0.280.0-r1::gentoo  USE="-test" 67 KiB
[ebuild   R    ] dev-perl/Net-Daemon-0.480.0-r2::gentoo  29 KiB
[ebuild   R    ] dev-perl/Socket6-0.280.0::gentoo  65 KiB
[ebuild   R    ] perl-core/File-Path-2.130.0::gentoo  31 KiB
[ebuild   R    ] perl-core/File-Temp-0.230.400-r1::gentoo  59 KiB
[ebuild     U  ] virtual/perl-Compress-Raw-Bzip2-2.74.0-r1::gentoo [2.69.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Digest-SHA-5.960.0::gentoo [5.950.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IO-Socket-IP-0.380.0::gentoo [0.370.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Sys-Syslog-0.350.0-r1::gentoo [0.330.100_rc-r3::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-if-0.60.600-r2::gentoo  0 KiB
[ebuild  rR    ] dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7%" 450 KiB
[ebuild     U  ] app-text/qpdf-8.1.0:0/21::gentoo [7.0.0:0/18::gentoo] USE="perl -doc -examples -static-libs -test" 8051 KiB
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-7.240.0::gentoo [7.100.200_rc-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/XML-Parser-2.440.0::gentoo  232 KiB
[ebuild     U  ] virtual/perl-Getopt-Long-2.490.0::gentoo [2.480.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r3::gentoo [0.18.0-r2::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-CBuilder-0.280.225-r2::gentoo  0 KiB
[ebuild     U  ] virtual/perl-JSON-PP-2.274.0.200_rc::gentoo [2.273.0.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-2.150.10-r1::gentoo [1.441.700.100_rc-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Perl-OSType-1.10.0-r1::gentoo [1.9.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-version-0.991.700::gentoo [0.991.600-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/IO-String-1.80.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/Text-CharWidth-0.40.0-r1::gentoo  9 KiB
[ebuild   R    ] perl-core/Module-CoreList-5.201.806.260::gentoo  103 KiB
[ebuild     U  ] virtual/perl-Digest-1.170.100_rc-r7::gentoo [1.170.100_rc-r3::gentoo] 0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-Constant-0.230.0-r11::gentoo  0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-Install-2.40.0-r3::gentoo  0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.700.0-r5::gentoo [1.700.0-r4::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.340.0::gentoo [3.310.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IO-Zlib-1.100.0-r11::gentoo [1.100.0-r10::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-IPC-Cmd-0.960.0::gentoo [0.920.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Locale-Maketext-1.280.0::gentoo [1.260.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Metadata-1.0.33-r1::gentoo [1.0.31-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Text-ParseWords-3.300.0-r4::gentoo [3.300.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-podlators-4.90.0::gentoo [4.70.0-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/Package-Constants-0.60.0::gentoo  4 KiB
[ebuild   R    ] dev-perl/String-ShellQuote-1.40.0-r1::gentoo  7 KiB
[ebuild   R    ] dev-perl/YAML-Syck-1.300.0::gentoo  167 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-Requirements-2.140.0-r3::gentoo [2.140.0-r2::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Locale-Maketext-Simple-0.210.100_rc-r7::gentoo [0.210.100_rc-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Math-Complex-1.590.100-r1::gentoo [1.590.0-r9::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Load-0.320.0-r6::gentoo [0.320.0-r5::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Load-Conditional-0.680.0-r1::gentoo [0.640.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Params-Check-0.380.0-r7::gentoo [0.380.0-r6::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Pod-Parser-1.630.0-r4::gentoo [1.630.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Pod-Simple-3.350.0-r1::gentoo [3.320.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Text-Balanced-2.30.0-r4::gentoo [2.30.0-r3::gentoo] 0 KiB
[ebuild  rR    ] media-libs/exiftool-11.03::gentoo  USE="-doc" 4311 KiB
[ebuild  rR    ] app-doc/NaturalDocs-1.52-r1::gentoo  450 KiB
[ebuild   R    ] virtual/perl-File-Temp-0.230.400-r5::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTTP-Date-6.20.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/HTML-Parser-3.720.0::gentoo  USE="-test" 89 KiB
[ebuild   R    ] virtual/perl-File-Path-2.130.0::gentoo  0 KiB
[ebuild     U  ] virtual/perl-IO-Compress-2.74.0-r1::gentoo [2.69.1_rc-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/TermReadKey-2.370.0::gentoo  USE="-examples" 84 KiB
[ebuild   R    ] dev-perl/Encode-Locale-1.50.0::gentoo  USE="-test" 9 KiB
[ebuild   R    ] dev-perl/Digest-HMAC-1.30.0-r1::gentoo  8 KiB
[ebuild   R    ] dev-perl/IO-HTML-1.1.0::gentoo  USE="-test" 19 KiB
[ebuild   R    ] dev-perl/MailTools-2.190.0::gentoo  USE="-examples -test" 55 KiB
[ebuild   R    ] dev-perl/Net-SSLeay-1.820.0::gentoo  USE="-examples -libressl -minimal -test" 390 KiB
[ebuild   R    ] dev-perl/PlRPC-0.202.0-r3::gentoo  18 KiB
[ebuild   R    ] dev-perl/Sub-Name-0.210.0::gentoo  USE="-suggested -test" 80 KiB
[ebuild   R    ] dev-perl/Text-Unidecode-1.300.0::gentoo  135 KiB
[ebuild   R    ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo  31 KiB
[ebuild   R    ] dev-perl/libintl-perl-1.280.0::gentoo  460 KiB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.460.0::gentoo  USE="-test" 0 KiB
[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.120.0::gentoo  USE="-test" 18 KiB
[ebuild   R    ] dev-perl/ExtUtils-PkgConfig-1.160.0::gentoo  10 KiB
[ebuild   R    ] dev-perl/ExtUtils-Depends-0.405.0::gentoo  USE="-test" 18 KiB
[ebuild   R    ] dev-perl/Locale-gettext-1.70.0::gentoo  9 KiB
[ebuild   R    ] dev-perl/XML-SAX-Base-1.90.0::gentoo  USE="-test" 28 KiB
[ebuild   R    ] dev-perl/common-sense-3.740.0-r1::gentoo  13 KiB
[ebuild   R    ] dev-perl/Canary-Stability-2012.0.0::gentoo  5 KiB
[ebuild   R    ] dev-perl/Exporter-Tiny-1.2.1::gentoo  USE="-examples -test" 32 KiB
[ebuild   R    ] dev-perl/IO-stringy-2.111.0::gentoo  41 KiB
[ebuild   R    ] dev-perl/Locale-Maketext-Lexicon-1.0.0::gentoo  USE="-test" 90 KiB
[ebuild   R    ] dev-perl/Log-Agent-1.1.0::gentoo  USE="-test" 55 KiB
[ebuild   R    ] dev-perl/MIME-Charset-1.12.2::gentoo  L10N="-ja -zh" 55 KiB
[ebuild   R    ] dev-perl/Text-CSV_XS-1.340.0::gentoo  USE="-examples -test" 170 KiB
[ebuild   R    ] dev-perl/Text-WrapI18N-0.60.0-r1::gentoo  4 KiB
[ebuild   R    ] dev-perl/XML-RegExp-0.40.0-r1::gentoo  4 KiB
[ebuild   R    ] dev-perl/XML-XPath-1.420.0::gentoo  USE="-examples -test" 55 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.150.10-r1::gentoo [2.150.5-r1::gentoo] 0 KiB
[ebuild   R    ] dev-perl/Date-Manip-6.600.0::gentoo  USE="-test" 1783 KiB
[ebuild   R    ] dev-perl/Digest-SHA1-2.130.0-r1::gentoo  39 KiB
[ebuild   R    ] dev-perl/Net-Telnet-3.40.0::gentoo  40 KiB
[ebuild   R    ] dev-perl/YAML-1.260.0::gentoo  USE="-test" 85 KiB
[ebuild   R    ] dev-perl/libxml-perl-0.80.0-r2::gentoo  63 KiB
[ebuild   R    ] virtual/perl-Module-CoreList-5.201.806.260::gentoo  0 KiB
[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.460.0-r1::gentoo  0 KiB
[ebuild  rR    ] sys-apps/texinfo-6.5::gentoo  USE="nls -static" 4398 KiB
[ebuild   R    ] dev-perl/DBI-1.637.0::gentoo  USE="-examples -test" 583 KiB
[ebuild   R    ] dev-perl/Try-Tiny-0.300.0::gentoo  USE="-minimal -test" 34 KiB
[ebuild   R    ] dev-perl/Authen-SASL-2.160.0-r1::gentoo  USE="kerberos" 45 KiB
[ebuild   R    ] dev-perl/CGI-4.400.0::gentoo  USE="-examples -test" 196 KiB
[ebuild   R    ] dev-perl/File-Listing-6.40.0-r1::gentoo  51 KiB
[ebuild   R    ] dev-perl/Module-Build-0.422.400::gentoo  USE="-test" 298 KiB
[ebuild   R    ] dev-perl/XML-SAX-1.0.0::gentoo  46 KiB
[ebuild   R    ] dev-perl/List-MoreUtils-XS-0.426.0::gentoo  USE="-test" 156 KiB
[ebuild   R    ] dev-perl/Types-Serialiser-1.0.0-r1::gentoo  7 KiB
[ebuild   R    ] dev-perl/Unicode-LineBreak-2017.4.0-r1::gentoo  305 KiB
[ebuild   R    ] dev-perl/glib-perl-1.326.0::gentoo  291 KiB
[ebuild   R    ] perl-core/Archive-Tar-2.300.0::gentoo  USE="-test" 63 KiB
[ebuild   R    ] dev-perl/Archive-Zip-1.600.0-r1::gentoo  USE="-examples -test" 187 KiB
[ebuild   R    ] dev-perl/Font-TTF-1.60.0::gentoo  251 KiB
[ebuild   R    ] dev-perl/Text-CSV-1.950.0::gentoo  USE="xs -test" 112 KiB
[ebuild  rR    ] app-misc/hivex-1.3.14::gentoo  USE="perl python readline -ocaml -ruby -static-libs -test" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6*" RUBY_TARGETS="ruby23 ruby24%* -ruby25% (-ruby22%)" 1302 KiB
[ebuild   R    ] dev-perl/URI-1.730.0::gentoo  USE="-test" 105 KiB
[ebuild   R    ] dev-perl/IO-Socket-SSL-2.52.0::gentoo  USE="-examples -idn" 217 KiB
[ebuild   R    ] dev-perl/Error-0.170.250::gentoo  USE="-test" 32 KiB
[ebuild   R    ] dev-perl/IO-Socket-INET6-2.720.0-r1::gentoo  27 KiB
[ebuild   R    ] dev-perl/IPC-System-Simple-1.250.0::gentoo  USE="-test" 30 KiB
[ebuild  r  U  ] media-gfx/graphite2-1.3.12-r1::gentoo [1.3.11::gentoo] USE="perl -test" ABI_X86="32 (64) (-x32)" 6512 KiB
[ebuild   R    ] dev-perl/SGMLSpm-1.1-r1::gentoo  112 KiB
[ebuild   R    ] dev-perl/JSON-XS-3.40.0::gentoo  USE="-examples -test" 82 KiB
[ebuild   R    ] dev-perl/Path-Class-0.370.0::gentoo  USE="-test" 37 KiB
[ebuild   R    ] dev-perl/XML-SAX-Expat-0.510.0::gentoo  USE="-test" 7 KiB
[ebuild   R    ] dev-perl/YAML-Tiny-1.730.0::gentoo  USE="-minimal -test" 72 KiB
[ebuild   R    ] perl-core/Test-Simple-1.302.96::gentoo  USE="-examples" 276 KiB
[ebuild  rR    ] xfce-base/xfconf-4.13.5:0/3::gentoo  USE="perl -debug -test" 596 KiB
[ebuild   R    ] dev-perl/Crypt-PasswdMD5-1.400.0::gentoo  7 KiB
[ebuild   R    ] dev-perl/DBD-SQLite-1.580.0::gentoo  USE="-system-sqlite -test" 2197 KiB
[ebuild   R    ] dev-perl/HTML-Tree-5.70.0::gentoo  USE="-test" 147 KiB
[ebuild   R    ] dev-perl/List-MoreUtils-0.426.0::gentoo  USE="xs -test" 143 KiB
[ebuild   R    ] dev-perl/Net-UPnP-1.4.3::gentoo  USE="-examples -test" 19 KiB
[ebuild   R    ] dev-perl/XML-Entities-1.0.200::gentoo  USE="-minimal -test" 21 KiB
[ebuild   R    ] dev-perl/XML-LibXML-2.13.200::gentoo  USE="-examples -minimal -test" 459 KiB
[ebuild   R    ] virtual/perl-Archive-Tar-2.300.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTTP-Message-6.130.0::gentoo  USE="-test" 73 KiB
[ebuild   R    ] dev-perl/File-BaseDir-0.70.0::gentoo  USE="-test" 10 KiB
[ebuild   R    ] dev-perl/Net-HTTP-6.170.0::gentoo  USE="-minimal -test" 38 KiB
[ebuild   R    ] dev-perl/Net-SMTP-SSL-1.40.0::gentoo  USE="-test" 3 KiB
[ebuild   R    ] dev-perl/WWW-RobotRules-6.20.0-r1::gentoo  9 KiB
[ebuild   R    ] dev-perl/JSON-2.940.0::gentoo  USE="xs -examples -test" 81 KiB
[ebuild   R    ] dev-perl/XML-Simple-2.250.0::gentoo  USE="-test" 77 KiB
[ebuild   R    ] virtual/perl-Test-Simple-1.302.96::gentoo  0 KiB
[ebuild   R    ] dev-perl/File-DesktopEntry-0.220.0::gentoo  USE="-test" 18 KiB
[ebuild   R    ] dev-perl/HTTP-Cookies-6.40.0::gentoo  USE="-test" 39 KiB
[ebuild   R    ] dev-perl/HTTP-Daemon-6.10.0-r2::gentoo  19 KiB
[ebuild   R    ] dev-perl/HTTP-Negotiate-6.10.0-r1::gentoo  9 KiB
[ebuild   R    ] dev-perl/File-MimeInfo-0.280.0::gentoo  USE="-test" 32 KiB
[ebuild   R    ] dev-perl/libwww-perl-6.270.0::gentoo  USE="ssl -test" 160 KiB
[ebuild   R    ] dev-perl/LWP-Protocol-https-6.70.0::gentoo  USE="-test" 9 KiB
[ebuild   R    ] dev-perl/XML-DOM-1.460.0-r1::gentoo  USE="-test" 115 KiB
[ebuild   R    ] dev-perl/Crypt-SSLeay-0.720.0-r2::gentoo  USE="-libressl -test" 127 KiB
[ebuild  rR    ] dev-db/postgresql-10.5:10::gentoo  USE="kerberos nls pam perl python readline (selinux) server ssl tcl threads xml zlib -doc -ldap -libressl -static-libs (-systemd) -uuid" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 19810 KiB
[ebuild  rR    ] dev-db/postgresql-11_beta3:11::gentoo  USE="kerberos nls pam perl python readline (selinux) server ssl tcl threads xml zlib -doc -ldap -libressl -llvm -static-libs (-systemd) -uuid" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 20875 KiB
[ebuild  rR    ] media-libs/ming-0.4.8-r1::gentoo  USE="perl php python -static-libs" PYTHON_TARGETS="python2_7" 14560 KiB
[ebuild  rR    ] app-editors/vim-8.1.0034::gentoo  USE="X acl lua nls perl python (selinux) tcl -cscope -debug -gpm -luajit -minimal -racket -ruby -terminal -vim-pager" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 13335 KiB
[ebuild     U  ] sys-libs/tdb-1.3.16::gentoo [1.3.14::gentoo] USE="python" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 493 KiB
[ebuild  rR    ] app-text/po4a-0.54::gentoo  USE="-test" 2624 KiB
[ebuild  rR    ] app-arch/dpkg-1.19.0.5::gentoo  USE="bzip2 lzma nls (selinux) unicode update-alternatives zlib -test" 4451 KiB
[ebuild  rR    ] net-nds/openldap-2.4.45::gentoo  USE="berkdb crypt ipv6 kerberos perl samba (selinux) ssl syslog -cxx -debug -experimental -gnutls -iodbc -kinit -libressl -minimal -odbc -overlays -pbkdf2 -sasl -sha2 -slp -smbkrb5passwd -static-libs -tcpd" ABI_X86="32 (64) (-x32)" 5552 KiB
[ebuild  rR    ] dev-util/debhelper-11.3.5::gentoo  USE="-test" L10N="-de -es -fr" 457 KiB
[ebuild     U  ] sys-libs/ldb-1.3.5:0/1.3.5::gentoo [1.1.29-r1:0/1.1.29::gentoo] USE="ldap* python -doc" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 1343 KiB
[ebuild   R    ] dev-perl/Tk-804.34.0::gentoo  USE="-examples -test" 6776 KiB
[ebuild   R    ] dev-perl/GD-2.660.0::gentoo  USE="gif jpeg png truetype -animgif -examples -fcgi -xpm" 248 KiB
[ebuild  rR    ] app-pda/pilot-link-0.12.5-r1::gentoo  USE="bluetooth java perl png python readline threads usb -debug -static-libs" PYTHON_TARGETS="python2_7" 1550 KiB
[ebuild   R    ] dev-perl/DBD-mysql-4.44.0::gentoo  USE="ssl -test" 152 KiB
[ebuild  rR    ] net-analyzer/net-snmp-5.8:0/35::gentoo  USE="X bzip2 ipv6 lm_sensors mfd-rewrites mysql perl python (selinux) ssl zlib -doc -elf -libressl -minimal -netlink -pci -rpm -smux -tcpd -ucd-compat" PYTHON_TARGETS="python2_7" 6441 KiB
[ebuild  rR    ] dev-vcs/subversion-1.10.2::gentoo  USE="apache2 berkdb extras http java nls perl python -ctypes-python -debug -doc -dso -gnome-keyring -kwallet -ruby -sasl -test -vim-syntax" PYTHON_TARGETS="python2_7" 8177 KiB
[ebuild  r  U  ] app-text/poppler-0.67.0:0/78::gentoo [0.57.0:0/68::gentoo] USE="cairo curl cxx introspection jpeg lcms nss png qt5 tiff utils -cjk -debug -doc -jpeg2k (-qt4%*)" 1426 KiB
[ebuild  rR    ] net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo  USE="graph lua perl python tcl -dbi -doc -rados -rrdcgi -ruby -static-libs -tcpd" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6%" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6%*" 2784 KiB
[ebuild  r  U  ] net-print/cups-filters-1.21.2::gentoo [1.20.4::gentoo] USE="dbus foomatic jpeg pdf perl png postscript tiff -ipp_autosetup -ldap -pclm -static-libs -test -zeroconf" 1439 KiB
[ebuild  rR    ] media-gfx/graphviz-2.40.1-r1::gentoo  USE="X cairo gtk java nls pdf perl python qt5 svg tcl -devil -doc -examples -gdk-pixbuf -gts -guile -lasi -postscript -ruby -static-libs" PYTHON_TARGETS="python2_7" 25033 KiB
[ebuild  r  U  ] media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo [7.0.6.9:0/7.0.6.9::gentoo] USE="X bzip2 cxx djvu fontconfig graphviz jpeg lcms lzma openexr pango perl png svg tiff truetype wmf xml zlib -corefonts -fftw -fpx -hdri -jbig -jpeg2k -lqr -opencl -openmp -postscript -q32 -q8 -raw -static-libs -test -webp" 8436 KiB
[ebuild  rR    ] dev-vcs/git-2.18.0::gentoo  USE="blksha1 cgi curl gpg iconv nls pcre pcre-jit perl python subversion threads tk webdav -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -test -xinetd" PYTHON_TARGETS="python2_7" 5399 KiB
[ebuild  r  U  ] app-editors/emacs-vcs-27.0.50_pre20180831:27::gentoo [27.0.50_pre20180731:27::gentoo] USE="X acl alsa dbus gif gmp%* gtk imagemagick inotify jpeg json kerberos lcms png (selinux) sound ssl svg threads tiff xpm zlib -Xaw3d (-aqua) -athena (-cairo) -dynamic-loading -games -gconf -gfile -gpm -gsettings -gtk2 -gzip-el -libxml2 -livecd -m17n-lib -mailutils -motif -source (-systemd) -toolkit-scroll-bars -wide-int -xft -xwidgets" 27997 KiB
[ebuild  rR    ] media-gfx/uniconvertor-2.0_pre379-r2::gentoo  PYTHON_TARGETS="python2_7" 1802 KiB
[ebuild  rR    ] media-video/dvdauthor-0.7.2-r2::gentoo  USE="imagemagick -graphicsmagick" 634 KiB
[ebuild  rR    ] dev-php/pecl-imagick-3.4.3::gentoo  USE="-examples -test" PHP_TARGETS="php5-6 php7-0 php7-1 -php7-2%" 240 KiB
[ebuild  r  U  ] net-fs/samba-4.8.4::gentoo [4.6.7::gentoo] USE="acl addc addns client cups fam gnutls gpg ldap* pam python (selinux) syslog winbind -ads -ceph% -cluster -debug (-dmapi) -iprint -quota (-system-heimdal) -system-mitkrb5 (-systemd) -test -zeroconf" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 17286 KiB
[ebuild  rR    ] media-gfx/inkscape-0.92.3::gentoo  USE="dbus exif imagemagick jpeg lcms nls openmp spell -cdr -dia -gnome -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 30866 KiB
[ebuild  rR    ] app-arch/alien-8.95-r1::gentoo  USE="bzip2" 56 KiB
[ebuild   R    ] app-admin/perl-cleaner-2.26-r1::gentoo  8 KiB
[ebuild  rR    ] net-dialup/freeradius-3.0.17::gentoo  USE="kerberos mysql pam pcap python readline samba sqlite ssl -debug -firebird -iodbc -ldap -libressl -memcached -odbc -oracle -postgres -rest" PYTHON_TARGETS="python2_7" 4730 KiB
[ebuild  r  U  ] app-text/texlive-core-2017-r4::gentoo [2017-r2::gentoo] USE="X luajittex tk -cjk -doc -source -xetex" 73174 KiB
[ebuild   R    ] dev-perl/Sys-Virt-3.9.1::gentoo  USE="-examples -test" 119 KiB
[ebuild  rR    ] net-irc/kvirc-5.0_pre20180819121252::gentoo  USE="dbus dcc_video gsm nls oss perl python spell ssl theora webkit -audiofile -debug -doc -kde -phonon -profile" PYTHON_TARGETS="python2_7" 5908 KiB
[ebuild  rR    ] net-libs/libproxy-0.4.13-r2::gentoo  USE="networkmanager perl python webkit -gnome -kde -mono -spidermonkey -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 88 KiB

Total: 200 packages (56 upgrades, 144 reinstalls), Size of downloads: 364408 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

virtual/perl-Scalar-List-Utils:0

  (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge) conflicts with
    =perl-Scalar-List-Utils-1.460.0-r1


The following packages are causing rebuilds:

  (dev-lang/perl-5.26.2:0/5.26::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (virtual/perl-IO-Socket-IP-0.380.0:0/0::gentoo, ebuild scheduled for merge)
    (app-editors/vim-8.1.0034:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Tk-804.34.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-NamespaceSupport-1.120.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Archive-Zip-1.600.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-Balanced-2.30.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/ming-0.4.8-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Path-Class-0.370.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libintl-perl-1.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-python/subunit-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Sub-Name-0.210.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-Maketext-Lexicon-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Digest-1.170.100_rc-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Package-Constants-0.60.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libxml-perl-0.80.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (sys-apps/texinfo-6.5:0/0::gentoo, ebuild scheduled for merge)
    (app-arch/alien-8.95-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-if-0.60.600-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-Requirements-2.140.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/String-ShellQuote-1.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (app-text/po4a-0.54:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-SQLite-1.580.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-MakeMaker-7.240.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-podlators-4.90.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/subversion-1.10.2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TimeDate-2.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Constant-0.230.0-r11:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Metadata-1.0.33-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/graphite2-1.3.12-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/WWW-RobotRules-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-Zlib-1.100.0-r11:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TermReadKey-2.370.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Carp-1.420.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Module-CoreList-5.201.806.260:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Crypt-SSLeay-0.720.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::gentoo, ebuild scheduled for merge)
    (net-libs/libproxy-0.4.13-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-misc/hivex-1.3.14:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-SSL-2.52.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Exporter-5.720.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-Unidecode-1.300.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Locale-Maketext-1.280.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/glib-perl-1.326.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Scalar-List-Utils-1.460.0:0/0::gentoo, ebuild scheduled for merge)
    (net-analyzer/net-snmp-5.8:0/35::gentoo, ebuild scheduled for merge)
    (virtual/perl-Archive-Tar-2.300.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Data-Dumper-2.167.0:0/0::gentoo, ebuild scheduled for merge)
    (net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo, ebuild scheduled for merge)
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Base-1.90.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-RegExp-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-stringy-2.111.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tree-5.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Font-TTF-1.60.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Math-Complex-1.590.100-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/GSSAPI-0.280.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Exporter-Tiny-1.2.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/PlRPC-0.202.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/ExtUtils-PkgConfig-1.160.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Path-2.130.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MIME-Charset-1.12.2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libwww-perl-6.270.0:0/0::gentoo, ebuild scheduled for merge)
    (xfce-base/xfconf-4.13.5:0/3::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-libs/exiftool-11.03:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Daemon-6.10.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Sys-Virt-3.9.1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Log-Agent-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Storable-2.620.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Test-Simple-1.302.96:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-MIME-Base64-3.150.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/JSON-2.940.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-db/postgresql-11_beta3:11/11::gentoo, ebuild scheduled for merge)
    (virtual/perl-IPC-Cmd-0.960.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Negotiate-6.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Path-2.130.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV_XS-1.340.0:0/0::gentoo, ebuild scheduled for merge)
    (net-dialup/freeradius-3.0.17:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-MimeInfo-0.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Date-Manip-6.600.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/SGMLSpm-1.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-libnet-3.100.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/Archive-Tar-2.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-Syck-1.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/URI-1.730.0:0/0::gentoo, ebuild scheduled for merge)
    (app-arch/dpkg-1.19.0.5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/DBD-mysql-4.44.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-Expat-0.510.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Digest-SHA-5.960.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-db/postgresql-10.5:10/10::gentoo, ebuild scheduled for merge)
    (dev-perl/DBI-1.637.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Daemon-0.480.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-DOM-1.460.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Sys-Syslog-0.350.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CSV-1.950.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Entities-1.0.200:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Canary-Stability-2012.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-util/debhelper-11.3.5:0/0::gentoo, ebuild scheduled for merge)
    (net-fs/samba-4.8.4:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Socket6-0.280.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Cookies-6.40.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-vcs/git-2.18.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-Telnet-3.40.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/YAML-1.260.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Scalar-List-Utils-1.460.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Load-0.320.0-r6:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-HTTP-6.170.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/ExtUtils-Depends-0.405.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-String-1.80.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (net-nds/openldap-2.4.45:0/0::gentoo, ebuild scheduled for merge)
    (net-irc/kvirc-5.0_pre20180819121252:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Simple-2.250.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Try-Tiny-0.300.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Parser-3.720.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Test-Harness-3.380.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Types-Serialiser-1.0.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-CoreList-5.201.806.260:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-HTML-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/List-MoreUtils-0.426.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/LWP-Protocol-https-6.70.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-DesktopEntry-0.220.0:0/0::gentoo, ebuild scheduled for merge)
    (app-pda/pilot-link-0.12.5-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Getopt-Long-2.490.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-XSLoader-0.270.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Digest-MD5-2.550.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Params-Check-0.380.0-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/IO-Socket-INET6-2.720.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-XPath-1.420.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/JSON-XS-3.40.0:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo, ebuild scheduled for merge)
    (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-Compress-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Parser-1.630.0-r4:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Spec-3.670.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Encode-2.880.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-version-0.991.700:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/List-MoreUtils-XS-0.426.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Locale-Maketext-Simple-0.210.100_rc-r7:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/MailTools-2.190.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-parent-0.236.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Load-Conditional-0.680.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Module-Build-0.422.400:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/HTTP-Message-6.130.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Parser-2.440.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/GD-2.660.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/CGI-4.400.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SMTP-SSL-1.40.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-BaseDir-0.70.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-IO-1.380.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Encode-Locale-1.50.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Error-0.170.250:0/0::gentoo, ebuild scheduled for merge)
    (app-doc/NaturalDocs-1.52-r1:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/graphviz-2.40.1-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-LibXML-2.13.200:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Perl-OSType-1.10.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Pod-Simple-3.350.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/common-sense-3.740.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-SAX-1.0.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-UPnP-1.4.3:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-LineBreak-2017.4.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Time-Local-1.250.0-r1:0/0::gentoo, ebuild scheduled for merge)
  (media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-video/dvdauthor-0.7.2-r2:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/uniconvertor-2.0_pre379-r2:0/0::gentoo, ebuild scheduled for merge)
    (dev-php/pecl-imagick-3.4.3:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/inkscape-0.92.3:0/0::gentoo, ebuild scheduled for merge)
    (app-editors/emacs-vcs-27.0.50_pre20180831:27/27::gentoo, ebuild scheduled for merge)
  (app-text/poppler-0.67.0:0/78::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-text/texlive-core-2017-r4:0/0::gentoo, ebuild scheduled for merge)
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/inkscape-0.92.3:0/0::gentoo, ebuild scheduled for merge)
  (app-text/qpdf-8.1.0:0/21::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-print/cups-filters-1.21.2:0/0::gentoo, ebuild scheduled for merge)


>>> Verifying ebuild manifests
>>> Running pre-merge checks for media-gfx/inkscape-0.92.3

>>> Emerging (1 of 200) dev-python/hyperlink-18.0.0::gentoo
 * Fetching files in the background.
 * To view fetch progress, run in another terminal:
 * tail -f /var/log/emerge-fetch.log
 * hyperlink-18.0.0.tar.gz BLAKE2B SHA512 size ;-) ...                                                                                                               [ ok ]
>>> Unpacking source...
>>> Unpacking hyperlink-18.0.0.tar.gz to /var/tmp/portage/dev-python/hyperlink-18.0.0/work
>>> Source unpacked in /var/tmp/portage/dev-python/hyperlink-18.0.0/work
>>> Preparing source in /var/tmp/portage/dev-python/hyperlink-18.0.0/work/hyperlink-18.0.0 ...
>>> Source prepared.
/usr/bin/pump: error: pump mode requested, but distcc hosts list does not contain any hosts with ',cpp' option
>>> Configuring source in /var/tmp/portage/dev-python/hyperlink-18.0.0/work/hyperlink-18.0.0 ...
>>> Source configured.
/usr/bin/pump: error: pump mode requested, but distcc hosts list does not contain any hosts with ',cpp' option
>>> Compiling source in /var/tmp/portage/dev-python/hyperlink-18.0.0/work/hyperlink-18.0.0 ...
 * python2_7: running distutils-r1_run_phase distutils-r1_python_compile
python2.7 setup.py build
running build
running build_py
.....
.....

And emerge finished the update successfully!

Last you should execute perl-cleaner

perl-cleaner will rebuild all perl modules and packages that have “perl” in their USE flags!

root@srv ~ # perl-cleaner --all       
 * Removing perl-core packages from world file
 *    emerge --deselect  perl-core/Archive-Tar perl-core/File-Path perl-core/File-Temp perl-core/Module-CoreList perl-core/Scalar-List-Utils perl-core/Test-Simple 
>>> Removing perl-core/Archive-Tar from "world" favorites file...
>>> Removing perl-core/File-Path from "world" favorites file...
>>> Removing perl-core/File-Temp from "world" favorites file...
>>> Removing perl-core/Module-CoreList from "world" favorites file...
>>> Removing perl-core/Scalar-List-Utils from "world" favorites file...
>>> Removing perl-core/Test-Simple from "world" favorites file...
 * Updating installed Perl virtuals
 *    emerge -u1  virtual/perl-Archive-Tar virtual/perl-CPAN-Meta virtual/perl-CPAN-Meta-Requirements virtual/perl-CPAN-Meta-YAML virtual/perl-Carp virtual/perl-Compress-Raw-Bzip2 virtual/perl-Compress-Raw-Zlib virtual/perl-Data-Dumper virtual/perl-Digest virtual/perl-Digest-MD5 virtual/perl-Digest-SHA virtual/perl-Encode virtual/perl-Exporter virtual/perl-ExtUtils-CBuilder virtual/perl-ExtUtils-Constant virtual/perl-ExtUtils-Install virtual/perl-ExtUtils-MakeMaker virtual/perl-ExtUtils-Manifest virtual/perl-ExtUtils-ParseXS virtual/perl-File-Path virtual/perl-File-Spec virtual/perl-File-Temp virtual/perl-Getopt-Long virtual/perl-IO virtual/perl-IO-Compress virtual/perl-IO-Socket-IP virtual/perl-IO-Zlib virtual/perl-IPC-Cmd virtual/perl-JSON-PP virtual/perl-Locale-Maketext virtual/perl-Locale-Maketext-Simple virtual/perl-MIME-Base64 virtual/perl-Math-Complex virtual/perl-Module-CoreList virtual/perl-Module-Load virtual/perl-Module-Load-Conditional virtual/perl-Module-Metadata virtual/perl-Params-Check virtual/perl-Parse-CPAN-Meta virtual/perl-Perl-OSType virtual/perl-Pod-Parser virtual/perl-Pod-Simple virtual/perl-Scalar-List-Utils virtual/perl-Storable virtual/perl-Sys-Syslog virtual/perl-Test-Harness virtual/perl-Test-Simple virtual/perl-Text-Balanced virtual/perl-Text-ParseWords virtual/perl-Time-Local virtual/perl-XSLoader virtual/perl-if virtual/perl-libnet virtual/perl-parent virtual/perl-podlators virtual/perl-version 

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) virtual/perl-Scalar-List-Utils-1.460.200_rc::gentoo
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/virtual/perl-Scalar-List-Utils-1.460.200_rc/work
>>> Preparing source in /var/tmp/portage/virtual/perl-Scalar-List-Utils-1.460.200_rc/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/virtual/perl-Scalar-List-Utils-1.460.200_rc/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/virtual/perl-Scalar-List-Utils-1.460.200_rc/work ...
>>> Source compiled.
>>> Test phase [not enabled]: virtual/perl-Scalar-List-Utils-1.460.200_rc

>>> Install perl-Scalar-List-Utils-1.460.200_rc into /var/tmp/portage/virtual/perl-Scalar-List-Utils-1.460.200_rc/image/ category virtual
>>> Completed installing perl-Scalar-List-Utils-1.460.200_rc into /var/tmp/portage/virtual/perl-Scalar-List-Utils-1.460.200_rc/image/

 * Final size of build directory: 4 KiB
 * Final size of installed tree:  4 KiB


>>> Installing (1 of 1) virtual/perl-Scalar-List-Utils-1.460.200_rc::gentoo
>>> Setting SELinux security labels

>>> Uninstalling perl-core/Scalar-List-Utils-1.460.0::gentoo

 perl-core/Scalar-List-Utils
    selected: 1.460.0 
   protected: none 
     omitted: none 

All selected packages: =perl-core/Scalar-List-Utils-1.460.0

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Unmerging perl-core/Scalar-List-Utils-1.460.0...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * Beginning a clean up of .ph files
 * Excluding files for 5.26.2 and 5.26.2/x86_64-linux-thread-multi from cleaning

 * Locating ph files for removal

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: dev-db/postgresql:11
 *   Adding to list: dev-db/postgresql:10
 *   Adding to list: app-pda/pilot-link:0
 *   Adding to list: media-gfx/graphviz:0
 *   Adding to list: media-gfx/graphite2:0
 *   Adding to list: media-gfx/imagemagick:0
 *   Adding to list: net-fs/samba:0
 *   Adding to list: net-irc/kvirc:0
 *   Adding to list: net-analyzer/rrdtool:0
 *   Adding to list: net-analyzer/net-snmp:0
 *   Adding to list: app-misc/hivex:0
 *   Adding to list: media-libs/ming:0
 *   Adding to list: dev-util/debhelper:0
 *   Adding to list: dev-util/perf:0
 *   Adding to list: app-arch/dpkg:0
 *   Adding to list: app-arch/alien:0
 *   Adding to list: net-nds/openldap:0
 *   Adding to list: app-text/po4a:0
 *   Adding to list: dev-vcs/subversion:0
 *   Adding to list: dev-vcs/git:0
 *   Adding to list: sys-libs/openipmi:0
 *   Adding to list: net-libs/libproxy:0
 *   Adding to list: xfce-base/xfconf:0
 * emerge -v1 --backtrack=200 --selective=n dev-db/postgresql:11 dev-db/postgresql:10 app-pda/pilot-link:0 media-gfx/graphviz:0 media-gfx/graphite2:0 media-gfx/imagemagick:0 net-fs/samba:0 net-irc/kvirc:0 net-analyzer/rrdtool:0 net-analyzer/net-snmp:0 app-misc/hivex:0 media-libs/ming:0 dev-util/debhelper:0 dev-util/perf:0 app-arch/dpkg:0 app-arch/alien:0 net-nds/openldap:0 app-text/po4a:0 dev-vcs/subversion:0 dev-vcs/git:0 sys-libs/openipmi:0 net-libs/libproxy:0 xfce-base/xfconf:0

 * IMPORTANT: 1 news items need reading for repository 'dlang'.
 * IMPORTANT: 20 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/ming-0.4.8-r1::gentoo  USE="perl php python -static-libs" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] app-misc/hivex-1.3.14::gentoo  USE="perl python readline -ocaml -ruby -static-libs -test" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6*" RUBY_TARGETS="ruby23 ruby24%* -ruby25% (-ruby22%)" 0 KiB
[ebuild   R    ] xfce-base/xfconf-4.13.5:0/3::gentoo  USE="perl -debug -test" 0 KiB
[ebuild     U  ] sys-libs/tdb-1.3.16::gentoo [1.3.14::gentoo] USE="python" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] net-nds/openldap-2.4.45::gentoo  USE="berkdb crypt ipv6 kerberos perl samba (selinux) ssl syslog -cxx -debug -experimental -gnutls -iodbc -kinit -libressl -minimal -odbc -overlays -pbkdf2 -sasl -sha2 -slp -smbkrb5passwd -static-libs -tcpd" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] dev-db/postgresql-11_beta3:11::gentoo  USE="kerberos nls pam perl python readline (selinux) server ssl tcl threads xml zlib -doc -ldap -libressl -llvm -static-libs (-systemd) -uuid" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 0 KiB
[ebuild   R    ] dev-db/postgresql-10.5:10::gentoo  USE="kerberos nls pam perl python readline (selinux) server ssl tcl threads xml zlib -doc -ldap -libressl -static-libs (-systemd) -uuid" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" 0 KiB
[ebuild     U  ] sys-libs/ldb-1.3.5:0/1.3.5::gentoo [1.1.29-r1:0/1.1.29::gentoo] USE="ldap* python -doc" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] media-gfx/graphite2-1.3.12-r1::gentoo [1.3.11::gentoo] USE="perl -test" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] app-text/po4a-0.54::gentoo  USE="-test" 0 KiB
[ebuild   R    ] app-arch/dpkg-1.19.0.5::gentoo  USE="bzip2 lzma nls (selinux) unicode update-alternatives zlib -test" 0 KiB
[ebuild   R    ] dev-util/debhelper-11.3.5::gentoo  USE="-test" L10N="-de -es -fr" 0 KiB
[ebuild   R    ] net-analyzer/rrdtool-1.7.0:0/8.0.0::gentoo  USE="graph lua perl python tcl -dbi -doc -rados -rrdcgi -ruby -static-libs -tcpd" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6%" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6%*" 0 KiB
[ebuild   R    ] app-pda/pilot-link-0.12.5-r1::gentoo  USE="bluetooth java perl png python readline threads usb -debug -static-libs" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] media-gfx/graphviz-2.40.1-r1::gentoo  USE="X cairo gtk java nls pdf perl python qt5 svg tcl -devil -doc -examples -gdk-pixbuf -gts -guile -lasi -postscript -ruby -static-libs" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] dev-util/perf-4.14.33::gentoo [4.9.13::gentoo] USE="audit demangle gtk numa perl python -debug -doc -slang -unwind" PYTHON_TARGETS="python2_7" 99293 KiB
[ebuild  r  U  ] media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo [7.0.6.9:0/7.0.6.9::gentoo] USE="X bzip2 cxx djvu fontconfig graphviz jpeg lcms lzma openexr pango perl png svg tiff truetype wmf xml zlib -corefonts -fftw -fpx -hdri -jbig -jpeg2k -lqr -opencl -openmp -postscript -q32 -q8 -raw -static-libs -test -webp" 0 KiB
[ebuild  r  U  ] app-editors/emacs-vcs-27.0.50_pre20180831:27::gentoo [27.0.50_pre20180731:27::gentoo] USE="X acl alsa dbus gif gmp%* gtk imagemagick inotify jpeg json kerberos lcms png (selinux) sound ssl svg threads tiff xpm zlib -Xaw3d (-aqua) -athena (-cairo) -dynamic-loading -games -gconf -gfile -gpm -gsettings -gtk2 -gzip-el -libxml2 -livecd -m17n-lib -mailutils -motif -source (-systemd) -toolkit-scroll-bars -wide-int -xft -xwidgets" 0 KiB
[ebuild  rR    ] media-gfx/uniconvertor-2.0_pre379-r2::gentoo  PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  rR    ] media-video/dvdauthor-0.7.2-r2::gentoo  USE="imagemagick -graphicsmagick" 0 KiB
[ebuild  rR    ] media-gfx/inkscape-0.92.3::gentoo  USE="dbus exif imagemagick jpeg lcms nls openmp spell -cdr -dia -gnome -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] net-analyzer/net-snmp-5.8:0/35::gentoo  USE="X bzip2 ipv6 lm_sensors mfd-rewrites mysql perl python (selinux) ssl zlib -doc -elf -libressl -minimal -netlink -pci -rpm -smux -tcpd -ucd-compat" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] sys-libs/openipmi-2.0.25::gentoo  USE="crypt perl python snmp tcl" PYTHON_TARGETS="python2_7" 3138 KiB
[ebuild   R    ] dev-vcs/subversion-1.10.2::gentoo  USE="apache2 berkdb extras http java nls perl python -ctypes-python -debug -doc -dso -gnome-keyring -kwallet -ruby -sasl -test -vim-syntax" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] dev-vcs/git-2.18.0::gentoo  USE="blksha1 cgi curl gpg iconv nls pcre pcre-jit perl python subversion threads tk webdav -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -test -xinetd" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] app-arch/alien-8.95-r1::gentoo  USE="bzip2" 0 KiB
[ebuild  rR    ] dev-php/pecl-imagick-3.4.3::gentoo  USE="-examples -test" PHP_TARGETS="php5-6 php7-0 php7-1 -php7-2%" 0 KiB
[ebuild     U  ] net-fs/samba-4.8.4::gentoo [4.6.7::gentoo] USE="acl addc addns client cups fam gnutls gpg ldap* pam python (selinux) syslog winbind -ads -ceph% -cluster -debug (-dmapi) -iprint -quota (-system-heimdal) -system-mitkrb5 (-systemd) -test -zeroconf" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] net-irc/kvirc-5.0_pre20180819121252::gentoo  USE="dbus dcc_video gsm nls oss perl python spell ssl theora webkit -audiofile -debug -doc -kde -phonon -profile" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild   R    ] net-libs/libproxy-0.4.13-r2::gentoo  USE="networkmanager perl python webkit -gnome -kde -mono -spidermonkey -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 0 KiB

Total: 30 packages (7 upgrades, 23 reinstalls), Size of downloads: 102431 KiB

The following packages are causing rebuilds:

  (media-gfx/imagemagick-7.0.8.11:0/7.0.8.11::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-video/dvdauthor-0.7.2-r2:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/uniconvertor-2.0_pre379-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-editors/emacs-vcs-27.0.50_pre20180831:27/27::gentoo, ebuild scheduled for merge)
    (dev-php/pecl-imagick-3.4.3:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/inkscape-0.92.3:0/0::gentoo, ebuild scheduled for merge)


>>> Verifying ebuild manifests
>>> Running pre-merge checks for media-gfx/inkscape-0.92.3

>>> Emerging (1 of 30) media-libs/ming-0.4.8-r1::gentoo
 * Fetching files in the background.
 * To view fetch progress, run in another terminal:
 * tail -f /var/log/emerge-fetch.log
 * ming-0_4_8.tar.gz BLAKE2B SHA512 size ;-) ...                                                                                                                     [ ok ]
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/media-libs/ming-0.4.8-r1/work
>>> Preparing source in /var/tmp/portage/media-libs/ming-0.4.8-r1/work/ming-0_4_8 ...
 * Applying ming-0.4.8-CVE-2017-8782.patch ...                                                                                                                       [ ok ]
 * Applying ming-0.4.8-freetype_pkgconfig.patch ...                                                                                                                  [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-libs/ming-0.4.8-r1/work/ming-0_4_8' ...
 * Running libtoolize --install --copy --force --automake ...                                                                                                        [ ok ]
 * Running aclocal -I macros ...                                                                                                                                     [ ok ]
 * This package has a configure.in file which has long been deprecated.  Please
 * update it to use configure.ac instead as newer versions of autotools will die
 * when it finds this file.  See https://bugs.gentoo.org/426262 for details.
 * Running autoconf --force ...                                                                                                                                      [ ok ]
 * Running autoheader ...                                                                                                                                            [ ok ]
 * Running automake --add-missing --copy --foreign --force-missing ...                                                                                               [ ok ]
 * Running elibtoolize in: ming-0_4_8/
 * Running elibtoolize in: ming-0_4_8/config/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.3 patch ...
>>> Source prepared.
.....
.....

One thought on “Gentoo updating perl with many masked and blocked packages”

Leave a Reply

Your email address will not be published.