gentoo emerge resume – Invalid resume list and clean the list

Under Gentoo and emerge it will eventually end up using “–resume” paired with “–skipfirst” emerge command, which should resume last list of packages to build without the first one. Each execution of emerge command should reset the list but apparently it might not be the case (in fact two lists are kept – resume and resume_backup, read below).
The command just reads a list of packages and emerges them – it’s fast and it does not go through the whole process of dependancy check! But sometimes the list could be old or get corrupted or it just throws errors for “Invalid resume list“:

dekstop ~ # emerge --resume --skipfirst

These are the packages that would be merged, in order:

Calculating dependencies... done!
 * Invalid resume list:
 * 
 *   ('ebuild', '/', 'kde-frameworks/kpty-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/libkscreen-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmbox-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kdesignerplugin-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kwayland-integration-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/xembed-sni-proxy-5.17.5', 'merge')
 *   ('ebuild', '/', 'net-libs/accounts-qml-0.7-r1', 'merge')
 *   ('ebuild', '/', 'kde-apps/akonadi-notes-19.12.1', 'merge')
....
....
 * One or more packages are either masked or have missing dependencies:
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/setuptools-40.6.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/setuptools-40.6.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/certifi-2018.8.24:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/certifi-2018.8.24:0/0::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/python-2.7.17-r1:2.7/2.7::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-util/glib-utils-2.56.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (sys-apps/file-5.35:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (sys-apps/file-5.35:0/0::gentoo, installed)
 * 
 *   >=dev-libs/icu-58.1:0/60.2= pulled in by:
 *     (dev-lang/spidermonkey-52.9.1_pre1:52/52::gentoo, installed)
....
....
 *   dev-lang/python:3.4 pulled in by:
 *     (virtual/python-enum34-1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (virtual/python-enum34-1:0/0::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/python-3.7.6:3.7/3.7m::gentoo, installed)
 * 
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.

Not all packages are included above, but it is clear that the list includes packages not only from the last emerge command. The list includes multiple old packages and dependencies about python:3.4, python:3.5, openssl:0/0.
The list is located in the binary file: /var/cache/edb/mtimedb and to clean the list you should execute:

desktop ~ # emaint --fix cleanresume
Emaint: fix cleanresume    100% [============================================>]

It is safe to the directory, too:

rm -Rf /var/cache/edb/

emaint is part of the sys-apps/portage package, so the program should always be available in the system.

*Bonus 1 – old packages

There is one more problem in the above example! In fact, you may clear the resume list with emaint or remove the whole directory “/var/cache/edb”, but still to receive such errors let’s say resuming log lists like KDE, gnome, qt packages (packages with many dependencies).

This problem persists not only with “–resume”, but also with “–keep-going” option!

When using “–keep-going” option you’ll get the same errors after the line “One or more packages are either masked or have missing dependencies”. So it is not an option, which may replace the “–resume” option.

Even all dependencies were resolved when the emerge list was generated when resuming a list of packages may throw errors for packages, which pull old packages because they had not been rebuilt against the updated of some of their dependencies. For example, simple enough from the above emerge resume command:
Some packages of our KDE resume list depends on the “dev-python/setuptools”, which has not been rebuilt against the new python (or after a removed old version python 3.4 and 3.5 or even another [old] package depends on the old python 3.5 and dev-python/setuptools, which has not been rebuilt after the python 3.4/3.5 removal!) and now this is a problem to resume the emerge list.

The solution is to take all those packages (after the line “One or more packages are either masked or have missing dependencies”) and rebuild or remove them.


Here is our full list:

desktop ~ # emerge -vu --resume --skipfirst                                

These are the packages that would be merged, in order:

Calculating dependencies... done!
 * Invalid resume list:
 * 
 *   ('ebuild', '/', 'kde-frameworks/kpty-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/libkscreen-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kwayland-integration-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/xembed-sni-proxy-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kservice-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kglobalaccel-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdebugsettings-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmbox-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/minuet-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kdesignerplugin-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kwrited-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/akonadi-notes-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kemoticons-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kpeople-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kdesu-5.66.0', 'merge')
 *   ('ebuild', '/', 'app-misc/geoclue-2.5.3-r2', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kfilemetadata-5.66.0', 'merge')
 *   ('ebuild', '/', 'media-video/pipewire-0.2.7', 'merge')
 *   ('ebuild', '/', 'sys-apps/xdg-desktop-portal-1.6.0', 'merge')
 *   ('ebuild', '/', 'media-libs/mlt-6.18.0-r1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/solid-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkcompactdisc-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kauth-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kconfigwidgets-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kiconthemes-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/ktextwidgets-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kwallet-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkmahjongg-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kgamma-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/polkit-kde-agent-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kxmlgui-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/signon-kwallet-extension-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/qqc2-desktop-style-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/ksshaskpass-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kwallet-pam-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kbookmarks-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkipi-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/blinken-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kbruch-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kcolorchooser-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kgeography-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmousetool-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/krfb-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kruler-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kcharselect-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kio-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kinit-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kded-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kparts-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/knewstuff-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kdeclarative-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/knotifyconfig-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/kpimtextedit-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkeduvocdocument-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/baloo-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/kipi-plugins-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kldap-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkcddb-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ffmpegthumbs-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kfind-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/thumbnailers-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kactivitymanagerd-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/filelight-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/juk-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kalzium-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kamera-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kbackup-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kcalc-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kcron-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdegraphics-mobipocket-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdenetwork-filesharing-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdialog-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kimap-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmag-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmouth-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ksmtp-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ksystemlog-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktimer-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kwave-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkomparediff2-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/zeroconf-ioslave-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kxmlrpcclient-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/xdg-desktop-portal-kde-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kapptemplate-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkdegames-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kcmutils-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kactivities-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kdelibs4support-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/ktexteditor-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/kidentitymanagement-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/khtml-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkleo-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/grantleetheme-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kio-extras-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kross-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/konsole-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/frameworkintegration-5.66.0-r1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ark-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/artikulate-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/baloo-widgets-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/dragon-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/gwenview-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kanagram-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdeaccessibility-meta-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdeadmin-meta-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdenlive-19.12.1-r1', 'merge')
 *   ('ebuild', '/', 'kde-apps/keditbookmarks-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/khangman-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/klettres-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmplot-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kontactinterface-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kteatime-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kturtle-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kwordquiz-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/spectacle-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/step-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/svgpart-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/drkonqi-5.17.5', 'merge')
 *   ('ebuild', '/', 'dev-vcs/kdesvn-2.1.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kdewebkit-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/plasma-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/kcalutils-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/kactivities-stats-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/audiocd-kio-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/bomber-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/bovo-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/cantor-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/dolphin-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/granatier-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/k3b-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kapman-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kate-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/katomic-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kblackbox-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kblocks-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kbounce-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kbreakout-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdf-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdiamond-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kfourinline-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kget-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kgoldrunner-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kig-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kigo-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/killbots-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kiriki-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kiten-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kjumpingcube-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/klickety-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/klines-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmahjongg-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmines-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/knavalbattle-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/knetwalk-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kolf-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kollision-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kolourpaint-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/konquest-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kopete-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kpat-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/krdc-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kreversi-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kshisen-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ksirk-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ksnakeduel-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kspaceduel-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ksquares-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ksudoku-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktouch-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktuberling-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kubrick-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kwalletmanager-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kwrite-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/lskat-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/okular-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/palapeli-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/picmi-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/rocs-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/yakuake-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/user-manager-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kajongg-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kde-dev-scripts-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kleopatra-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kompare-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kross-interpreters-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/umbrello-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-misc/kdeconnect-1.3.5', 'merge')
 *   ('ebuild', '/', 'kde-misc/krusader-2.7.2', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/krunner-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-plasma/libksysguard-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdegraphics-meta-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/knights-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-desktop-applets-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/sweeper-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-pa-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/ksysguard-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/milou-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdegames-meta-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-vault-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/breeze-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-integration-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/breeze-gtk-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kscreenlocker-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kwin-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/libkworkspace-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kde-cli-tools-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kaccounts-integration-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/khelpcenter-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/khotkeys-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/kmix-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/print-manager-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/bluedevil-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kde-gtk-config-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kinfocenter-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kscreen-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-nm-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/powerdevil-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/sddm-kcm-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/systemsettings-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/akonadi-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-common-internals-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-frameworks/purpose-5.66.0', 'merge')
 *   ('ebuild', '/', 'kde-apps/kaccounts-providers-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kmenuedit-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/akonadi-contacts-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/akonadi-mime-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-contact-list-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-filetransfer-handler-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kamoso-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-accounts-kcm-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-auth-handler-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-call-ui-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-contact-runner-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-kded-module-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-browser-integration-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-apps/akonadi-search-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdemultimedia-meta-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kgpg-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-approver-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/ktp-send-file-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/libkdepim-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/pimcommon-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/kdepim-apps-libs-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-apps/libgravatar-19.12.1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-workspace-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/oxygen-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/kdeplasma-addons-5.17.5', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-desktop-5.17.5-r1', 'merge')
 *   ('ebuild', '/', 'kde-plasma/plasma-meta-5.17.5', 'merge')
 * 
 * One or more packages are either masked or have missing dependencies:
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/setuptools-40.6.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/setuptools-40.6.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/certifi-2018.8.24:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/certifi-2018.8.24:0/0::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/python-2.7.17-r1:2.7/2.7::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-util/glib-utils-2.56.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (sys-apps/file-5.35:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (sys-apps/file-5.35:0/0::gentoo, installed)
 * 
 *   >=dev-libs/icu-58.1:0/60.2= pulled in by:
 *     (dev-lang/spidermonkey-52.9.1_pre1:52/52::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (sys-libs/cracklib-2.9.6-r1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (sys-libs/cracklib-2.9.6-r1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4[threads(+)] pulled in by:
 *     (dev-python/cython-0.29.1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[threads(+)] pulled in by:
 *     (dev-python/cython-0.29.1:0/0::gentoo, installed)
 * 
 *   >=dev-libs/icu-3.8.1-r1:0/60.2= pulled in by:
 *     (net-libs/webkit-gtk-2.22.4:4/37::gentoo, installed)
 * 
 *   dev-lang/perl:0/5.24= pulled in by:
 *     (net-fs/samba-4.6.7:0/0::gentoo, installed)
 * 
 *   >=sys-libs/talloc-2.1.9[python,python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+),abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (net-fs/samba-4.6.7:0/0::gentoo, installed)
 * 
 *   >=sys-libs/tdb-1.3.12[python,python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+),abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (net-fs/samba-4.6.7:0/0::gentoo, installed)
 * 
 *   >=sys-libs/tevent-0.9.31-r1[python,python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+),abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (net-fs/samba-4.6.7:0/0::gentoo, installed)
 * 
 *   dev-python/dnspython:py2/py2=[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+)] pulled in by:
 *     (net-fs/samba-4.6.7:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (app-crypt/gpgme-1.12.0:1/11::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (app-crypt/gpgme-1.12.0:1/11::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (media-sound/pulseaudio-12.2:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4[threads(+)] pulled in by:
 *     (dev-python/dbus-python-1.2.8:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[threads(+)] pulled in by:
 *     (dev-python/dbus-python-1.2.8:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/pygobject-3.28.3-r1:3/3::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/pygobject-3.28.3-r1:3/3::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/setuptools_scm-2.1.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/setuptools_scm-2.1.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/pycparser-2.19:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/pycparser-2.19:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/decorator-4.3.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/decorator-4.3.0:0/0::gentoo, installed)
 * 
 *   dev-libs/icu:0/60.2= pulled in by:
 *     (dev-libs/libical-3.0.3:0/3::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (media-libs/alsa-lib-1.1.7:0/0::gentoo, installed)
 * 
 *   dev-libs/icu:0/60.2=[abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (dev-db/sqlite-3.25.3:3/3::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/python-3.6.10:3.6/3.6m::gentoo, installed)
 * 
 *   dev-lang/python:3.4[threads(+)] pulled in by:
 *     (app-portage/gemato-14.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[threads(+)] pulled in by:
 *     (app-portage/gemato-14.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4[threads(+)] pulled in by:
 *     (dev-util/scons-3.0.1-r100:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[threads(+)] pulled in by:
 *     (dev-util/scons-3.0.1-r100:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (net-libs/gupnp-1.0.3:0/4::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (sys-fs/cryptsetup-2.0.6:0/12::gentoo, installed)
 * 
 *   >=dev-qt/qtcore-4.8.6:4[abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (dev-libs/libdbusmenu-qt-0.9.3_pre20160218:0/0::gentoo, installed)
 * 
 *   >=dev-qt/qtdbus-4.8.6:4[abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (dev-libs/libdbusmenu-qt-0.9.3_pre20160218:0/0::gentoo, installed)
 * 
 *   >=dev-qt/qtgui-4.8.6:4[abi_x86_32(-),abi_x86_64(-)] pulled in by:
 *     (dev-libs/libdbusmenu-qt-0.9.3_pre20160218:0/0::gentoo, installed)
 * 
 *   acct-group/plugdev pulled in by:
 *     (media-libs/libmtp-1.1.16:0/9::gentoo, installed)
 * 
 *   dev-libs/icu:0/60.2= pulled in by:
 *     (sci-libs/libqalculate-2.8.1:0/20::gentoo, installed)
 * 
 *   dev-libs/boost:0/1.65.0= pulled in by:
 *     (media-libs/qt-gstreamer-1.2.0-r4:0/0::gentoo, installed)
 * 
 *   >=dev-libs/openssl-0.9.8g:0/0=[-bindist] pulled in by:
 *     (net-voip/telepathy-gabble-0.18.4-r1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (net-libs/libsignon-glib-1.14:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (net-libs/libsignon-glib-1.14:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (app-admin/system-config-printer-1.5.11-r1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4[ssl(+)] pulled in by:
 *     (dev-python/urllib3-1.23:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[ssl(+)] pulled in by:
 *     (dev-python/urllib3-1.23:0/0::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-python/cryptography-2.3.1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4[threads(+)] pulled in by:
 *     (dev-python/cryptography-2.3.1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[threads(+)] pulled in by:
 *     (dev-python/cryptography-2.3.1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4[threads(+)] pulled in by:
 *     (dev-python/requests-2.19.1-r1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5[threads(+)] pulled in by:
 *     (dev-python/requests-2.19.1-r1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-python/attrs-18.1.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-python/attrs-18.1.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (dev-libs/libpwquality-1.4.0:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (dev-libs/libpwquality-1.4.0:0/0::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-libs/libgit2-0.27.7:0/27::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (app-accessibility/speech-dispatcher-0.8.7:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (app-accessibility/speech-dispatcher-0.8.7:0/0::gentoo, installed)
 * 
 *   media-video/ffmpeg:0/55.57.57= pulled in by:
 *     (media-libs/opencv-2.4.13-r3:0/2.4::gentoo, installed)
 * 
 *   ~sys-devel/gcc-5.4.0[gcj] pulled in by:
 *     (dev-java/gcj-jdk-5.4.0-r1:0/0::gentoo, installed)
 * 
 *   sys-devel/gcc:*[gcj] pulled in by:
 *     (dev-java/ecj-gcj-4.4.2:4.4/4.4::gentoo, installed)
 * 
 *   >=dev-libs/openssl-1.0.0:0/0= pulled in by:
 *     (dev-db/mysql-5.7.24:0/18::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/ruby-2.4.4-r1:2.4/2.4::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/ruby-2.6.5:2.6/2.6::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/ruby-2.5.7:2.5/2.5::gentoo, installed)
 * 
 *   dev-lang/python:3.4 pulled in by:
 *     (virtual/python-enum34-1:0/0::gentoo, installed)
 * 
 *   dev-lang/python:3.5 pulled in by:
 *     (virtual/python-enum34-1:0/0::gentoo, installed)
 * 
 *   dev-libs/openssl:0/0= pulled in by:
 *     (dev-lang/python-3.7.6:3.7/3.7m::gentoo, installed)
 * 
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.

One might think it just a simple rebuild of the above packages? No, you may encounter additional dependency errors like:

desktop ~ # emerge -v dev-python/setuptools                               

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-python/setuptools-44.0.0::gentoo [40.6.2::gentoo] USE="-test" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8% (-pypy%) (-python3_4%*) (-python3_5%*)" 839 KiB

Total: 1 package (1 upgrade), Size of downloads: 839 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

  (dev-python/setuptools-44.0.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -pypy3 -python3_7 -python3_8" pulled in by
    dev-python/setuptools (Argument)

  (dev-python/setuptools-40.6.2:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7" pulled in by
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/protobuf-python-3.6.1:0/17::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pytest-3.8.2:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/pykerberos-1.1.9:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/jinja-2.10:0/0::gentoo, installed) USE="-doc -examples -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/cryptography-2.3.1:0/0::gentoo, installed) USE="-libressl -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                              
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pip-10.0.1:0/0::gentoo, installed) USE="-vanilla" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/cssutils-1.0.2:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gemato-14.0:0/0::gentoo, installed) USE="blake2 bzip2 gpg lzma -sha3 -test -tools" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (sys-apps/file-5.35:0/0::gentoo, installed) USE="python zlib -static-libs" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (media-gfx/scour-0.36:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (media-libs/mutagen-1.40.0:0/0::gentoo, installed) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_4(-),python_targets_python3_5(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pastedeploy-1.5.2-r2:0/0::gentoo, installed) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

You must resolve (manually) the dependency conflict before continuing with the first emerge.

Leave a Reply

Your email address will not be published.